Kattis - Eight Queens

Eight Queens

In the game of chess, the queen is a powerful piece. It can attack by moving any number of spaces in its current row, in its column or diagonally.

In the eight queens puzzle, eight queens must be placed on a standard $8 \times 8$ chess board so that no queen can attack another. The center figure below shows an invalid solution; two queens can attack each other diagonally. The figure on the right shows a valid solution. Given a description of a chess board, your job is to determine whether or not it represents a valid solution to the eight queens puzzle.

\includegraphics[width=0.7\textwidth ]{chess}
Figure 1: Queen movement (left), invalid solution (center), valid solution (right).

Input

Input will contain a description of a single chess board, given as eight lines of eight characters each. Input lines will consist of only the characters ‘.’ and ‘*’. The ‘.’ character represents an empty space on the board, and the ‘*’ character represents a queen.

Output

Print a single line of output. Print the word “valid” if the given chess board is a valid solution to the eight queens problem. Otherwise, print “invalid”.

Sample Input 1Sample Output 1
*.......
..*.....
....*...
......*.
.*......
.......*
.....*..
...*....
invalid
Sample Input 2Sample Output 2
*.......
......*.
....*...
.......*
.*......
...*....
.....*..
..*.....
valid

题意

检查一下给出的棋盘是否是八个皇后都无法攻击到任何人的,唯一一个坑点大概就是皇后一定要8个。。。

代码

#include<stdio.h>
#include<string.h>
#include<math.h>
int main() {
    char ch[9][9],i,j;
    int xx[100];
    int yy[100];
    while (~scanf("%s",ch[0]))
    {
        for (i = 1; i < 8; i++)
        {
            scanf("%s", ch[i]);
        }
        int c = 0;
        for (i = 0; i < 8; i++)
        {
            for (j = 0; j < 8; j++)
            {
                if (ch[i][j] == '*')
                {
                    xx[c] = i;
                    yy[c] = j;
                    c++;
                }
            }
        }
        int flag = 0;
        if (c != 8)
        {
            flag = 1;
        }
        if (c == 8)
        {
            for (i = 0; i < 8; i++)
            {
                for (j = i + 1; j < 8; j++)
                {
                    if (xx[i] == xx[j] || yy[i] == yy[j] || fabs(xx[i] - xx[j]) == fabs(yy[i] - yy[j]))
                    {
                        flag = 1;
                    }
                }
                if (flag)break;
            }
        }
        puts(flag ? "invalid" : "valid");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/zhien-aa/p/6284123.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值