HDU 2844 Coins (多重背包计数 空间换时间)


Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8999    Accepted Submission(s): 3623

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 
Output
For each test case output the answer on a single line.
 
Sample Input
 
   
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 
Sample Output
 
   
8 4
 
Source
2009 Multi-University Training Contest 3 - Host by WHU

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2844

题目大意:n种数,每一个数的值为ai,有ci个,求能组成多少个不大于m的不同的数字
 
题目分析:这题的数据量实在感人。三层循环(枚举种类,枚举数值。枚举个数)肯定超时,要想办法减去一层循环,细致分析能够发现个数的那层循环能够省掉,代价是耗费很多其他的空间。开一个cnt数组记录当前第i种使用了多少个,其他两层循环不变,然后就是普通的背包计数问题


#include <cstdio>
#include <cstring>
int const MAXM = 1e5 + 5;
int const MAXN = 1e2 + 5;
bool dp[MAXM];
int cnt[MAXM];
int a[MAXN], c[MAXN];

int  main()
{
    int n, m;
    while(scanf("%d %d", &n, &m) != EOF && (n + m))
    {
        memset(dp, false, sizeof(dp));
        for(int i = 1; i <= n; i ++)
            scanf("%d", &a[i]);
        for(int i = 1; i <= n; i ++)
            scanf("%d", &c[i]);
        dp[0] = true;
        int ans = 0;
        for(int i = 1; i <= n; i ++)
        {
            memset(cnt, 0, sizeof(cnt));
            for(int s = a[i]; s <= m; s ++)
            {
                if(!dp[s] && dp[s - a[i]] && cnt[s - a[i]] < c[i])
                {
                    dp[s] = true;
                    ans ++;
                    cnt[s] = cnt[s - a[i]] + 1;
                }
            }
        }
        printf("%d\n", ans);
    }
}


转载于:https://www.cnblogs.com/liguangsunls/p/7040444.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值