poj2236 Wireless Network 并查集

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

     In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
 
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS


题意:
有n个电脑毁坏,并且只有距离小于d的两个相邻计算机可以相互联系,当然,计算机之间也可以通过计算机形成通路,现在有两种操作,O是修复计算机ai;P是询问任意两台计算机能否联络,给出回答,SUCCESS或者FAIL。
题解:
很标准的并查集类型题,每个电脑都有一个坐标,构造结构体进行存储数据,结构体中也包括pre,表示是以这个坐标为一个整体,判断电脑可否联通,其中要添加一个use数组,用来判断P操作时的计算机有无被修复过。

代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
struct node
{
    int x,y,pre;
}p[1005];

int use[1005],d;

int Find(int a)
{
    return a==p[a].pre?a:Find(p[a].pre);
}

void join(node a,node b)
{
    int root1,root2;
    root1=Find(a.pre);
    root2=Find(b.pre);
    if(root1!=root2)
        if((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)<=d*d)
            p[root2].pre=root1;
}

int main()
{
    int n,i,a,b;
    char m;
    cin>>n>>d;
    for(i=0;i<=n;i++) p[i].pre=i;
    memset(use,false,sizeof(use));
    for(i=1;i<=n;++i)
        scanf("%d%d",&p[i].x,&p[i].y);
    while(scanf("\n%c",&m)!=EOF)
    {
        if(m =='O')
        {
            scanf("%d",&a);
            use[a]=true;
            for(i=1;i<=n;++i)
                if(use[i]&&i!=a)
                    join(p[i],p[a]);
        }
        else
        {
            scanf("%d%d",&a,&b);
            if(Find(a)==Find(b))
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/y1040511302/p/9622650.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值