E - Fibonacci Again(找规律)

逐渐发现找规律的美妙之处啦,真不错,用普通方法解决很久或者很麻烦的问题,找到规律就很方便,算法最主要还是思想

Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2). 
 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000). 
 

Output

Print the word "yes" if 3 divide evenly into F(n). 

Print the word "no" if not. 
 

Sample Input

0 1 2 3 4 5
 

Sample Output

no no yes no no no
 
问题描述:
  对于以7, 11,为f(0)和f(1)的斐波那契数列,f(n) = f(n-1) + f(n-2);
  输入项数n,问第n项是否能被三整除
 
这样一个斐波那契数列很大很大,特别是测试项数还比较多,用大数存储也能做,但是比较麻烦,可以打表找规律
打表代码:
#include <stdio.h>
long long a[100];
void init()
{
    a[0] = 7;
    a[1] = 11;
    for(int i = 2; i < 100; i++)
    {
        a[i] = a[i-1]+a[i-2];
    }
}
int main()
{
    init();
    for(int i = 0; i < 100; i++)
    {
        printf("a[%d] = %lld\n", i, a[i]);
        if(a[i] % 3 == 0)
            printf("*****\n");
    }
    return 0;
}

发现每四项有一个满足要求的,所以代码如下:

#include <stdio.h>

int main()
{
    long long n;
    while(scanf("%lld", &n)!= EOF)
    {
        if(n % 4 == 2)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/rain-1/p/4885430.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值