牛牛的字符串

题目描述
牛牛有两个字符串(可能包含空格),他想找出其中最长的公共连续子串的长度,希望你能帮助他。例如:两个字符串分别为"abede"和"abgde",结果为2。
输入
每组数据包括两行,每行为一个字符串。
输出
输出最长的公共连续子串的长度。
样例输入 Copy
abede
abgde
样例输出 Copy
2

#include<bits/stdc++.h>
using namespace std;
int fun(char p[],char q[],int c[50][50])
{
    int max=0;
    for(int i=0;i<strlen(p);i++)
    {
         c[0][i]=0;
    }
    for(int i=0;i<strlen(q);i++)
    {
        c[i][0]=0;
    }
    for(int i=0;i<strlen(p);i++)
    {
        for(int j=0;j<strlen(q);j++)
        {
            if(i==0||j==0)
            {
                if(p[i]==q[j])
                    c[i][j]=1;
            }
            else
            {
               if(p[i]==q[j])
              {
                c[i][j]=c[i-1][j-1]+1;
              }
            }
            if(c[i][j]>max)
            {
                max=c[i][j];
            }
        }
    }
    return max;
}
int main()
{
    char p[100];
    char q[100];
    int c[50][50];
    while(cin>>p)
    {
         cin>>q;
        fun(p,q,c);
        cout<<fun(p,q,c)<<endl;
    }
       return 0;
}

 

转载于:https://www.cnblogs.com/zl222333zl/p/10746158.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值