HDU 5615 Jam's math problem

Jam's math problem

Problem Description
Jam has a math problem. He just learned factorization.
He is trying to factorize ax^2+bx+c into the form of pqx^2+(qk+mp)x+km=(px+k)(qx+m).
He could only solve the problem in which p,q,m,k are positive numbers.
Please help him determine whether the expression could be factorized with p,q,m,k being postive.
 
Input
The first line is a number T, means there are T(1 <=T <=100 ) cases

Each case has one line,the line has 3 numbers a,b,c (1 <= a,b,c <=100000000)
 
Output
You should output the "YES" or "NO".
 
Sample Input
2
1 6 5
1 6 4
 
Sample Output
YES
NO
Hint
The first case turn x^2+6*x+5 into (x+1)(x+5)
 
Recommend
hujie
题目大意:输入abc,问ax*x+bx+c=0能否因式分解
思路:只要判断qk+mp与b是否相等(a==pq,c==km)
注意:循环q可以用p==a/q,用i*i<=a可以防止重复的情况。。。
#include <stdio.h>
int main()
{
        int a, b, c, i, j, T, flag;
        scanf("%d", &T);
        while(T--)
        {
        flag=1;
        scanf("%d%d%d", &a, &b, &c);
        for(i=1;flag&&i*i<=a;i++)
        {
        if(a%i==0)
        for(j=1;flag&&j*j<=c;j++)
        if(c%j==0)
        if(i*j+(a/i)*(c/j)==b||i*(c/j)+j*(a/i)==b)
        flag=0;
        }
        if(!flag) printf("YES\n");
        else printf("NO\n");
        }
        return 0;
}

 

 

转载于:https://www.cnblogs.com/Noevon/p/5425905.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值