Counting Rectangles

Counting Rectangles
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1043 Accepted: 546

Description
We are given a figure consisting of only horizontal and vertical line segments. Our goal is to count the number of all different rectangles formed by these segments. As an example, the number of rectangles in the Figures 1 and 2 are 5 and 0 respectively.

There are many intersection points in the figure. An intersection point is a point shared by at least two segments. The input line segments are such that each intersection point comes from the intersection of exactly one horizontal segment and one vertical segment.

Input
The first line of the input contains a single number M, which is the number of test cases in the file (1 <= M <= 10), and the rest of the file consists of the data of the test cases. Each test case begins with a line containing s (1 <= s <= 100), the number of line segments in the figure. It follows by s lines, each containing x and y coordinates of two end points of a segment respectively. The coordinates are integers in the range of 0 to 1000.

Output
The output for each test case is the number of all different rectangles in the figure described by the test case. The output for each test case must be written on a separate line.

Sample Input

2
6
0 0 0 20
0 10 25 10
20 10 20 20
0 0 10 0
10 0 10 20
0 20 20 20
3
5 0 5 20
15 5 15 25
0 10 25 10

Sample Output

5
0
给你水平还有竖直的线段判断可以组成多少的矩形
暴力姿势

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define LL long long
using namespace std;

const int MAX = 11000;

struct node
{
    int x1;
    int y1;
    int x2;
    int y2;
}H[120],S[120];

int top1,top2;

bool Judge(int h,int s)
{
    if(S[s].y1>=H[h].y1&&S[s].y1<=H[h].y2&&H[h].x2>=S[s].x1&&H[h].x2<=S[s].x2)
    {
        return true;
    }
    return false;
}

int main()
{
    int T;
    int n;
    int x1,y1,x2,y2;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        top1=0;
        top2=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
            if(x1==x2)
            {
                H[top1].x1=x1;H[top1].y1=min(y1,y2);
                H[top1].x2=x2;H[top1].y2=max(y1,y2);
                top1++;
            }
            else if(y1==y2)
            {
                S[top2].x1=min(x1,x2);S[top2].y1=y1;
                S[top2].x2=max(x1,x2);S[top2].y2=y2;
                top2++;
            }
        }
        int sum=0;
        for(int i=0;i<top1;i++)
        {
            for(int j=0;j<top2;j++)
            {
                if(Judge(i,j))
                {
                    for(int k=i+1;k<top1;k++)
                    {
                        if(Judge(k,j))
                        {
                            for(int s=j+1;s<top2;s++)
                            {
                                if(Judge(i,s)&&Judge(k,s))
                                {
                                    sum++;
                                }
                            }
                        }
                    }
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

转载于:https://www.cnblogs.com/juechen/p/5255997.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值