Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13020 Accepted: 5832
Description
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
Source
USACO 2007 February Silver
/*****************************
author : Grant Yuan
time : 2014/10/4 23:07
source : POJ 3268
algorithm: Dijkstra
******************************/
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define MAX 1007
#define INF 0x7ffffff
struct point{int x,y;};
int n,m,x;
int ans;
point v[MAX];
int cost[MAX][MAX];
bool used[MAX];
int mincost[MAX];
int start,final;
int sum[MAX];
void Dijkstra_Go()
{
for(int i=1;i<=n;i++)
{
used[i]=false;
mincost[i]=cost[i][x];
}
for(int i=1;i<=n;i++)
{
int temp=INF;
int k=-1;
for(int j=1;j<=n;j++)
{
if(!used[j]&&mincost[j]<temp)
{
temp=mincost[j];
k=j;
}
}
if(k==-1) break;
used[k]=true;
for(int j=1;j<=n;j++)
{
if(!used[j]) mincost[j]=min(mincost[j],mincost[k]+cost[j][k]);
}
}
}
void Dijkstra_Back()
{
for(int i=1;i<=n;i++)
{
used[i]=false;
mincost[i]=cost[x][i];
}
for(int i=1;i<=n;i++)
{
int temp=INF;int k=-1;
for(int j=1;j<=n;j++)
{
if(!used[j]&&mincost[j]<temp)
{
temp=mincost[j];
k=j;
}
}
if(k==-1) break;
used[k]=true;
for(int j=1;j<=n;j++)
{
if(!used[j]) mincost[j]=min(mincost[j],mincost[k]+cost[k][j]);
}
}
}
int main()
{
while(~scanf("%d%d%d",&n,&m,&x)){
ans=0;
memset(sum,0,sizeof(sum));
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
cost[i][j]=INF;
for(int i=1;i<=n;i++) cost[i][i]=0;
for(int i=1;i<=m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
cost[a][b]=c;
}
Dijkstra_Go();
for(int i=1;i<=n;i++)
{
sum[i]=mincost[i];
}
Dijkstra_Back();
for(int i=1;i<=n;i++)
{
sum[i]+=mincost[i];
}
for(int i=1;i<=n;i++) ans=max(ans,sum[i]);
printf("%d\n",ans);}
return 0;
}