usaco1.4.4(milk3)

题目:

Mother's Milk

Farmer John has three milking buckets of capacity A, B, and C liters. Each of the numbers A, B, and C is an integer from 1 through 20, inclusive. Initially, buckets A and B are empty while bucket C is full of milk. Sometimes, FJ pours milk from one bucket to another until the second bucket is filled or the first bucket is empty. Once begun, a pour must be completed, of course. Being thrifty, no milk may be tossed out.

Write a program to help FJ determine what amounts of milk he can leave in bucket C when he begins with three buckets as above, pours milk among the buckets for a while, and then notes that bucket A is empty.

PROGRAM NAME: milk3

INPUT FORMAT

A single line with the three integers A, B, and C.

SAMPLE INPUT (file milk3.in)

8 9 10

OUTPUT FORMAT

A single line with a sorted list of all the possible amounts of milk that can be in bucket C when bucket A is empty.

SAMPLE OUTPUT (file milk3.out)

1 2 8 9 10

SAMPLE INPUT (file milk3.in)

2 5 10

SAMPLE OUTPUT (file milk3.out)

5 6 7 8 9 10
都说了是搜索,红果果的DFS
代码:
/*
ID:614433244
PROG: milk3
LANG: C++
*/

#include"iostream"
#include"cstdio"
#include"memory.h"
#include"algorithm"
using namespace std;
bool map[21][21][21]={0};
int ans[25],head=-1;
bool flag[25]={0};
int a,b,c;
void dfs( int x,int y,int z )
{
    if( map[x][y][z] )
        return;
    else
    {
        map[x][y][z]=1;
        if( x==0&&flag[z]==0 )
        {
            head++;
            ans[head]=z;
            flag[z]=1;
        }
        //A->B
        if( x+y<=b )
            dfs( 0,x+y,z );
        else
            dfs( x-( b-y ),b,z );

        //A->C
        if( x+z<=c )
            dfs( 0,y,x+z );
        else
            dfs( x+z-c,y,c );

        //B->A
        if( x+y<=a )
            dfs( x+y,0,z );
        else
            dfs( a,x+y-a,z );

        //B->C
        if( y+z<=c )
            dfs( x,0,y+z );
        else
            dfs( x,y+z-c,c );

        //C->A
        if( x+z<=a )
            dfs( x+z,y,0 );
        else
            dfs( a,y,x+z-a );

        //C->B
        if( y+z<=b )
            dfs( x,y+z,0 );
        else
            dfs( x,b,y+z-b );
    }
}

int main()
{
    freopen("milk3.in","r",stdin);
    freopen("milk3.out","w",stdout);
    scanf("%d%d%d",&a,&b,&c);
    dfs( 0,0,c );
    sort( ans,ans+head+1 );
    int i;
    for( i=0;i<head;i++ )
        printf("%d ",ans[i]);
    printf("%d\n",ans[i]);
    return 0;
}

不过因为节点走过了就无需再走,所以无需记住回溯




转载于:https://www.cnblogs.com/rolyxiao/archive/2012/07/14/2591532.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值