hdu 5119 Happy Matt Friends dp

Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)


Problem Description
Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.
 

 

Input
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 10 6).

In the second line, there are N integers ki (0 ≤ k i ≤ 10 6), indicating the i-th friend’s magic number.
 

 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
 

 

Sample Input
2 3 2 1 2 3 3 3 1 2 3
 

 

Sample Output
Case #1: 4 Case #2: 2
Hint
In the first sample, Matt can win by selecting: friend with number 1 and friend with number 2. The xor sum is 3. friend with number 1 and friend with number 3. The xor sum is 2. friend with number 2. The xor sum is 2. friend with number 3. The xor sum is 3. Hence, the answer is 4.
 

 

Source
题意:N个数,选异或和大于等于M的方案数;
思路:类似求背包方案总数;
#include<bits/stdc++.h>
using namespace std;
#define ll __int64
#define esp 1e-13
const int N=2e3+10,M=1e6+50000,inf=1e9+10,mod=1000000007;
ll dp[42][M];
int a[N];
void init()
{
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
}
int main()
{
    int x,y,i,z,t;
    int T,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        init();
        scanf("%d%d",&x,&y);
        for(i=1;i<=x;i++)
        scanf("%d",&a[i]);
        for(i=1;i<=x;i++)
        {
            for(t=0;t<M;t++)
            dp[i][t^a[i]]+=dp[i-1][t],dp[i][t]+=dp[i-1][t];
        }
        ll ans=0;
        for(i=y;i<M;i++)
        ans+=dp[x][i];
        printf("Case #%d: %I64d\n",cas++,ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jhz033/p/5760064.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值