ACM: 限时训练题解-Street Lamps-贪心-字符串【超水】

  1. Street Lamps

 

Bahosain is walking in a street of N blocks. Each block is either empty or has one lamp. If there is a lamp in a block, it will light it’s block and the direct adjacent blocks. For example, if there is a lamp at block 3, it will light the blocks 2, 3, and 4.

 

Given the state of the street, determine the minimum number of lamps to be installed such that each block is lit.

 

Input

 

The first line of input contains an integer T (1 ≤ T ≤   1025) that represents the number of test cases.

 

The first line of each test case contains one integer N (1 ≤ N ≤ 100) that represents the number of blocks in the street.

 

The next line contains N characters, each is either a dot ’.’ or an asterisk   ’*’.

 

A dot represents an empty block, while an asterisk represents a block with a lamp installed in it.

 

Output

 

For each test case, print a single line with the minimum number of lamps that have to be installed so that all blocks are lit.

 

 

 

Sample Input

Sample Output

3

2

6

0

......

1

3

 

*.*

 

8

 

.*.....*

 

 

 

 

/*
这题纯水。 
*/


#include"iostream"
#include"algorithm"
#include"cstdio"
#include"cstring"
#include"cmath"
#define MX 100 + 5
using namespace std;

char s[MX];
bool ss[MX];

int main() {
	int T,ans,len;
	scanf("%d",&T);
	while(T--) {
		memset(ss,0,sizeof(ss));
		memset(s,0,sizeof(s));
		scanf("%d%s",&len,s+1);
		ans=0;
		for(int i=1; i<=len; i++) {
			if(s[i]=='*') {
				ss[i-1]=ss[i]=ss[i+1]=1; //把已经照亮的地方标记为 1 
			}
		}
		int tot=0;
		for(int i=1; i<=len; i++) {
			if(ss[i]) {				//统计每一个没亮的地方的长度 
				ans+=(tot+2)/3;     //除3 向上取整 
				tot=0;
			}
			else tot++;
		}
		ans+=(tot+2)/3;
		printf("%d\n",ans);
	}
	return 0;
}

  

 

转载于:https://www.cnblogs.com/HDMaxfun/p/5709392.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值