hdu2824 The Euler function(欧拉函数个数)

版权声明:本文为博主原创文章,未经博主同意不得转载。

vasttian https://blog.csdn.net/u012860063/article/details/36426357

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2824

欧拉函数性质:

1:(百科):http://baike.baidu.com/link?url=r-yneKCCyS9N6bhbQCqiZX0V2OCYq9r7iHSzHTSs03H7qRvu1OfUzlOxfVEs2PmR

2:http://www.cppblog.com/doer-xee/archive/2009/12/01/102353.html


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 
Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 
Output
Output the result of (a)+ (a+1)+....+ (b)
 
Sample Input
 
    
3 100
 
Sample Output
 
    
3042
 
Source

题意:求a到b中每一个数的欧拉函数的总和!


代码例如以下:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
#define N 3000001

__int64 phi[N];

void init()
{
    int i, j;
    for(i = 1; i < N; i++)
        phi[i] = i;

    for(i = 2; i < N; i++)
        if(i == phi[i]) //此时i为素数
            for(j = i; j < N; j += i)  //j累加i
                phi[j] = (phi[j] / i) * (i - 1); //j有因子i,并且i是素数,正是欧拉函数
}

int main()
{
    init();
    int a, b;
    while(scanf("%d%d", &a, &b) != EOF)
    {
        __int64 ans = 0;
        for(int i = a; i <= b; i++)
            ans += phi[i];
        printf("%I64d\n", ans);
    }
    return 0;
}


转载于:https://www.cnblogs.com/mqxnongmin/p/10704295.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值