Codeforces Round #285 (Div. 2)C. Misha and Forest(拓扑排序)

传送门

Description

Let's define a forest as a non-directed acyclic graph (also without loops and parallel edges). One day Misha played with the forest consisting of n vertices. For each vertex v from 0 to n - 1 he wrote down two integers, degreev and sv, were the first integer is the number of vertices adjacent to vertex v, and the second integer is the XOR sum of the numbers of vertices adjacent to v (if there were no adjacent vertices, he wrote down 0).

Next day Misha couldn't remember what graph he initially had. Misha has values degreev and sv left, though. Help him find the number of edges and the edges of the initial graph. It is guaranteed that there exists a forest that corresponds to the numbers written by Misha.

Input

The first line contains integer n (1 ≤ n ≤ 216), the number of vertices in the graph.

The i-th of the next lines contains numbers degreei and si (0 ≤ degreei ≤ n - 1, 0 ≤ si < 216), separated by a space.

Output

In the first line print number m, the number of edges of the graph.

Next print m lines, each containing two distinct numbers, a and b (0 ≤ a ≤ n - 1, 0 ≤ b ≤ n - 1), corresponding to edge (a, b).

Edges can be printed in any order; vertices of the edge can also be printed in any order.

Sample Input

3
2 3
1 0
1 0
 
  
2
1 1
1 0

Sample Output

2
1 0
2 0
 
  
1
0 1

Note

The XOR sum of numbers is the result of bitwise adding numbers modulo 2. This operation exists in many modern programming languages. For example, in languages C++, Java and Python it is represented as "^", and in Pascal — as "xor".

思路

题意:

有一个森林包含0-n-1这n个节点,给出每个节点与它相邻节点的个数以及与它相邻节点的异或和,问有几条边,每条边的连接的两个节点是多少。

题解:

 可以看作是一个拓扑排序,每次找出只有一个节点与之相邻的节点,那么与之相邻的节点的序号就是这个节点的异或和。

 

#include<bits/stdc++.h>
using namespace std;
const int maxn = (1<<16)+5;
int deg[maxn],sum[maxn];

int main()
{
	int n;
	queue<int>que;
	scanf("%d",&n);
	for (int i = 0;i < n;i++)
	{
		scanf("%d%d",&deg[i],&sum[i]);
		if (deg[i] == 1)	que.push(i);
	}
	vector<pair<int,int> >ans;
	while (!que.empty())
	{
		int u = que.front();
		que.pop();
		if (deg[u] == 0)	continue;
		int v = sum[u];
		ans.push_back(make_pair(u,v));
		deg[v]--,sum[v] ^= u;
		if (deg[v] == 1)	que.push(v);
	}
	int size = ans.size();
	printf("%d\n",size);
	for (int i = 0;i < size;i++)	printf("%d %d\n",ans[i].first,ans[i].second);
	return 0;
}

  

转载于:https://www.cnblogs.com/ZhaoxiCheung/p/6911124.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值