poj2385 - Apple Catching【动态规划】

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

Source

USACO 2004 November

思路:首先,我们定义了一个num数组,其中num[0][i]表示第i分钟时第一颗树掉苹果,num[1][i]表示第i分钟时第二颗树掉苹果。

我们可以推导

1. 当j==0时,也就是说没有移动一次,dp[i][j]=dp[i-1][j]+num[0][i];

2. 当j!=0时, dp[i][j]=max(dp[i-1][j],dp[i-1][j-1])+num[j%2==1][i];其中num数组是判断他要去的那棵树是否有苹果掉下来。

大概思路就是这样,具体细节看代码。

#include<cstdio>
#include<cstring>
#include <iostream>
using namespace std;
const int maxn=1005;
int num[2][maxn],dp[maxn][35];

int main()
{
    int t,w;
    scanf("%d%d",&t,&w);
    memset(num,0,sizeof(num));
    for(int i=1;i<=t;++i)
    {
        int x;
        scanf("%d",&x);
        if(x==1)           //第一颗树掉苹果
            num[0][i]=1;
        else               //第二颗树掉苹果
            num[1][i]=1;
    }
    memset(dp,0,sizeof(dp));
    dp[1][0]=num[0][1],dp[1][1]=num[1][1];  //初始化,临界条件
    for(int i=2;i<=t;++i)
    {
        for(int j=0;j<=w && j<=i;++j)
        {
            if(j==0)
                dp[i][j]=dp[i-1][j]+num[0][i];
            else
                dp[i][j]=max(dp[i-1][j],dp[i-1][j-1])+num[j%2==1][i];
        }       //转移与不转移比较,选择较大值
    }
    printf("%d\n",dp[t][w]);
    return 0;
}

 

转载于:https://www.cnblogs.com/aerer/p/9930916.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值