高精度练习

题目地址:http://acm.hust.edu.cn/vjudge/problem/30812

Xiao Ming's Hope

Description

Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C (n,1)+C (n,2)+...+C (n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C (1,0)=C (1,1)=1, there are 2 odd numbers. When n is equal to 2, C (2,0)=C (2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?

Input

Each line contains a integer n(1<=n<=10 8)

Output

A single line with the number of odd numbers of C (n,0),C (n,1),C (n,2)...C (n,n).

Sample Input

1

2

11

Sample output

2

2

8

 

 

题目大意:C (n,0),C (n,1),C (n,2)...C (n,n).中有多少个奇数。

要求这些组合数中奇数的个数,那么也就是C(n,m)%2 == 1 的个数。首先,由Lucas定理可知C(n,m)%2 等于C(n%2,m%2)*(C(n/2,m/2)%2,而只有C(0,1) = 0 ,所以当n的某一二进制位为0时,m的必为0,那么考虑为n的二进制位为1的时候,m的二进制既可以为1也可以为0就能保证形成的数是奇数,所以最终结果是2^(n的二进制位中1的个数)。

 

#include <cstdio>
using namespace std;
int n;
int main(void)
{
    while (scanf("%d",&n) != EOF)
    {
        int cnt = 0;
        while(n)
        {
            if(n&1) cnt++;  //如果是奇数,cnt加1
            n >>= 1;        //相当于n /= 2
        }
        printf ( "%d\n" , 1<<cnt );//>>1为二进制有意义为,即除2, 1<<为左移一位,即乘2。
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/Muia/p/5734273.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值