【POJ 1717】Dominoes(dp)

Dominoes
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6729 Accepted: 2233

Description

A domino is a flat, thumbsized tile, the face of which is divided into two squares, each left blank or bearing from one to six dots. There is a row of dominoes laid out on a table: 

The number of dots in the top line is 6+1+1+1=9 and the number of dots in the bottom line is 1+5+3+2=11. The gap between the top line and the bottom line is 2. The gap is the absolute value of difference between two sums. 

Each domino can be turned by 180 degrees keeping its face always upwards. 

What is the smallest number of turns needed to minimise the gap between the top line and the bottom line? 

For the figure above it is sufficient to turn the last domino in the row in order to decrease the gap to 0. In this case the answer is 1. 
Write a program that: computes the smallest number of turns needed to minimise the gap between the top line and the bottom line.

Input

The first line of the input contains an integer n, 1 <= n <= 1000. This is the number of dominoes laid out on the table. 

Each of the next n lines contains two integers a, b separated by a single space, 0 <= a, b <= 6. The integers a and b written in the line i + 1 of the input file, 1 <= i <= 1000, are the numbers of dots on the i-th domino in the row, respectively, in the top line and in the bottom one. 

Output

Output the smallest number of turns needed to minimise the gap between the top line and the bottom line.

Sample Input

4
6 1
1 5
1 3
1 2

Sample Output

1

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

[题意][给定两排n个数,问当两排之差的和最小时,最少交换了几次]
【题解】【dp】
【一个较简单的dp,设f[i][j]为枚举到第i个数,差为j时最少交换了多少次。要考虑j为负数的情况,所以要加eps】
【方程:f[i][j]=min(f[i][j],min(f[i-1][j-(a[i]-b[i])],f[i-1][j+(a[i]-b[i])]+1)。刚开始读入时,预处理每次交换当前值的情况】

#include<cstdio>
#include<cstring>
#include<algorithm>
#define eps 5000
using namespace std;
int a[1010],b[1010],n,f[1010][10010];
int ans,num,sum,inf;
int main()
{
//	freopen("int.txt","r",stdin);
//	freopen("my.txt","w",stdout);
	int i,j;
	scanf("%d",&n); 
	memset(f,127,sizeof(f));
	inf=f[0][0];
	for(i=1;i<=n;++i)
	 {
	 	scanf("%d%d",&a[i],&b[i]);
	 	int x=a[i],y=b[i];
	 	f[i][sum+x-y+eps]=0; f[i][sum+y-x+eps]=1;
	 	sum+=(x-y);
	 }
    for(i=2;i<=n;++i)
     for(j=-5000;j<=5000;++j)
      {
      	int x=a[i],y=b[i],ch=x-y,sm;
      	sm=min(f[i-1][j-ch+eps],f[i-1][j+ch+eps]+1);
      	f[i][j+eps]=min(f[i][j+eps],sm);
	  }
	for(i=0;i<=5000;++i)
	 if(f[n][i+eps]!=inf) 
      {
      	ans=f[n][i+eps]; num=i;
      	break;
	  }
	for(i=0;i>=-5000;--i)
	 if(f[n][i+eps]!=inf)
	  if(-i<num) ans=f[n][i+eps],num=-i;
	   else
	    if(-i==num) {ans=min(ans,f[n][i+eps]); break;}
	printf("%d\n",ans);
	return 0;
}


转载于:https://www.cnblogs.com/lris-searching/p/9403015.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值