HDU 4391 Paint The Wall(分块+延迟标记)

Paint The Wall

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3427    Accepted Submission(s): 955

Problem Description
As a amateur artist, Xenocide loves painting the wall. The wall can be considered as a line consisting of n nodes. Each node has its own color.

Xenocide spends all day in front of the wall. Sometimes, he paints some consecutive nodes so that these nodes have the same color. When he feels tired, he focuses on a particular color and counts the number of nodes that have this color within a given interval.

Now Xenocide is tired of counting, so he turns to you for help.
 

 

Input
The input consists of several test cases.
The first line of each test case contains two integer n, m(1<=n, m<=100000) indicating the length of the wall and the number of queries.
The following line contains N integers which describe the original color of every position.
Then m lines follow. Each line contains 4 non-negative integers a, l, r, z(1<=a<=2, 0<=l<=r<n , 0<=z<231).
a = 1 indicates that Xenocide paints nodes between l and r and the resulting color is z.
a = 2 indicates that Xenocide wants to know how many nodes between l and r have the color z.
 

 

Output
Print the corresponding answer for each queries.
 

 

Sample Input
5 5
1 2 3 4 0
2 1 3 3
1 1 3 1
2 1 3 3
2 0 3 1
2 3 4 1
 

 

Sample Output
1
0
4
1
 

 

题目链接:HDU 4391

一开始一看以为是线段树,虽然这题有很多人线段树+剪枝过的,如果用的是区间最大值最小值剪枝,粗略一想确实剪枝挺强,它用了一种二分的思想——区间大小跟最大值最小值之差肯定是存在单调不减的关系,但是对于特殊数据就没戏了,比如151515151515,然后查询1,n,3,这样一来3确实一直在1~5之间,但是会一直递归到根节点,最后却连发现一个3都没有,因此这题正解之一应该是分块算法,每一个块维护这个块所控制区间的颜色及每一个颜色的数量信息,此处有分块的区间更新操作,因此需要lazy的思想,跟线段树一样,整块打标记,标记传递时把信息传递到真实数组里去,学习一个分块下的延迟标记的用法,最后注意一下题目中的数组都是从0开始的

代码:

#include <bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
typedef pair<int, int> pii;
typedef long long LL;
const double PI = acos(-1.0);
const int N = 100010;
const int M = sqrt(N) + 10;
struct block
{
	int color, l, r;
	map<int, int>info;
	inline int len()
	{
		return r - l + 1;
	}
};
block B[M];
int arr[N], belong[N];
int unit, bcnt;

void init(int n)
{
	unit = sqrt(n);
	bcnt = n / unit;
	if (n % unit)
		++bcnt;
	for (int i = 1; i <= bcnt; ++i)
	{
		B[i].l = (i - 1) * unit + 1;
		B[i].r = i * unit;
		B[i].color = -1;
		B[i].info.clear();
	}
	B[bcnt].r = n;
	for (int i = 1; i <= n; ++i)
	{
		belong[i] = (i - 1) / unit + 1;
		++B[belong[i]].info[arr[i]];
	}
}
void pushdown(int x)
{
	if (~B[x].color)
	{
		for (int i = B[x].l; i <= B[x].r; ++i)
			arr[i] = B[x].color;
		B[x].info.clear();
		B[x].info[B[x].color] = B[x].len();
		B[x].color = -1;
	}
}
void update(int l, int r, int c)
{
	int bl = belong[l], br = belong[r];
	for (int i = bl + 1; i < br; ++i)
		B[i].color = c;
	if (bl != br)
	{
		pushdown(bl);
		pushdown(br);
		for (int i = l; i <= B[bl].r; ++i)
		{
			--B[bl].info[arr[i]];
			++B[bl].info[c];
			arr[i] = c;
		}
		for (int i = B[br].l; i <= r; ++i)
		{
			--B[br].info[arr[i]];
			++B[br].info[c];
			arr[i] = c;
		}
	}
	else
	{
		pushdown(bl);
		for (int i = l; i <= r; ++i)
		{
			--B[bl].info[arr[i]];
			++B[bl].info[c];
			arr[i] = c;
		}
	}
}
int query(int l, int r, int c)
{
	int ret = 0;
	int bl = belong[l], br = belong[r];
	for (int i = bl + 1; i < br; ++i) //先处理中间
	{
		if (~B[i].color)
			ret += B[i].len() * (B[i].color == c);
		else
		{
			if (B[i].info.find(c) != B[i].info.end())
				ret += B[i].info[c];
		}
	}
	if (bl == br)
	{
		pushdown(bl);
		for (int i = l; i <= r; ++i)
			ret += (arr[i] == c);
	}
	else
	{
		pushdown(bl);
		pushdown(br);
		for (int i = l; i <= B[bl].r; ++i)
			ret += (arr[i] == c);
		for (int i = B[br].l; i <= r; ++i)
			ret += (arr[i] == c);
	}
	return ret;
}
int main(void)
{
	int n, m, a, l, r, z, i;
	while (~scanf("%d%d", &n, &m))
	{
		for (i = 1; i <= n; ++i)
			scanf("%d", &arr[i]);
		init(n);
		while (m--)
		{
			scanf("%d%d%d%d", &a, &l, &r, &z);
			++l, ++r;
			if (a == 1)
				update(l, r, z);
			else
				printf("%d\n", query(l, r, z));
		}
	}
	return 0;
}

转载于:https://www.cnblogs.com/Blackops/p/6842969.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值