poj3348 Cows

Cows
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10039 Accepted: 4408

Description

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input

4
0 0
0 101
75 0
75 101

Sample Output

151

Source

大致题意:n个点,用一个绳子圈出尽可能大的面积,养一头牛要50的面,最多能养多少头?
分析:凸包模板题.几个要点:1.找极点,将序号设为1. 2.根据极角和极点的距离排序. 3.维护一个最少有2个点的栈,再来考虑每个点能不能加进来,加进来会将多少个点从栈中删除,利用叉积判断.  4.利用叉积求面积.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

int n,tot,ans;

struct node
{
    int x,y;
}p[10010],q[10010];

node sub(node a,node b)
{
    node temp;
    temp.x = a.x - b.x;
    temp.y = a.y - b.y;
    return temp;
}

int det(node a,node b)
{
    return a.x * b.y - a.y * b.x;
}

int dist(node a)
{
    return (a.x - p[1].x) * (a.x - p[1].x) + (a.y - p[1].y) * (a.y - p[1].y);
}

bool cmp(node a,node b)
{
    int temp = det(sub(a,p[1]),sub(b,p[1]));
    if (temp != 0)
        return temp > 0;
    return dist(a) < dist(b);
}

void Graham()
{
    int id = 1;
    for (int i = 2; i <= n; i++)
    {
        if (p[i].x < p[id].x || (p[i].x == p[id].x && p[i].y < p[id].y))
            id = i;
    }
    if (id != 1)
        swap(p[1],p[id]);
    sort(p + 2,p + 1 + n,cmp);
    q[++tot] = p[1];
    for (int i = 2; i <= n; i++)
    {
        while (tot >= 2 && det(sub(p[i],q[tot - 1]),sub(q[tot],q[tot - 1])) >= 0)
            tot--;
        q[++tot] = p[i];
    }
}

int solve()
{
    int res = 0;
    q[tot + 1] = q[1];
    for (int i = 1; i <= tot; i++)
        res += det(q[i],q[i + 1]);
    return res / 2;
}

int main()
{
    scanf("%d",&n);
    for (int i = 1; i <= n; i++)
        scanf("%d%d",&p[i].x,&p[i].y);
    Graham();
    ans = solve();
    printf("%d\n",ans / 50);

    return 0;
}

 

转载于:https://www.cnblogs.com/zbtrs/p/8111436.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值