杭电ACM 1008解题报告

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 26436    Accepted Submission(s): 14247

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 
Output
Print the total time on a single line for each test case.  
 
Sample Input
1 2 3 2 3 1 0
 
Sample Output
17 41
 
代码:

#include<iostream>

using namespace std;

int main()

{  

  int n;  

  int m[100];  

  while(cin>>n)  

  {   

    int a=n,i=0,j,k,sum=0;   

    if(n==0)    

      break;   

    else   

    {    

      while(a--)     

      cin>>m[i++];    

      sum+=6*m[0];    

      for(i=0;i<n-1;i++)    

      {     

        if(m[i+1]>m[i])      

          sum+=6*(m[i+1]-m[i]);                 // 如果i+1层大于i层,就用层数之间的差乘以6

        else  if(m[i+1]<=m[i])       

          sum+=4*(m[i]-m[i+1]);                // 如果i+1层小于等于i层,就用层数之间的差乘以4 

      }    

      sum+=5*n;                                             //每到一层电梯停留,所以每次要乘以5

    }   

    cout<<sum<<endl;  

  }  

return 0;

}

 

转载于:https://www.cnblogs.com/Reack/archive/2012/11/04/Reack.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值