TOJ 1258 Very Simple Counting

Description

Let f(n) be the number of factors of integer n.

Your task is to count the number of i(1 <= i < n) that makes f(i) = f(n).

Input

One n per line (1 < n <= 1000000).

There are 10000 lines at most.

Output

For each n, output counting result in one line.

Sample Input

4
5

Sample Output

0
2

Hint

f(1) = 1, f(2) = f(3) = f(5) = 2, f(4) = 3.

Source

ZOJ Monthly 2009.12

 

比赛的一道题目,一看到这种题目就头晕了。

后来看了别人的解题报告,cjx才有了点思路。

首先要记录下每个数的因子的个数,然后把因子的个数当做下标的索引。这样就可以记录与当前数的因子数相同的因子的个数。

这样子还不够,发现每次记录的时候都需要通过f[i]先去找他因子的个数是多少,放到输入里面还会超时。

果断继续打表,用s[i]来记录比i小且当前i因子数相同的个数。

 

#include <stdio.h>
#define MAXN 1000001

int f[MAXN]={0};
int s[MAXN]={0};
int c[MAXN]={0};

int main()
{
    //先求出每个数的因子数 
    for(int i=1; i<MAXN; i++){
        for(int j=1; i*j<MAXN; j++){
            f[i*j]++;
        }
    }
    //统计比i小且因子数相同的数  
    for(int i=1; i<MAXN; i++){
        s[i]=c[f[i]];
        c[f[i]]++;
    }
    int n;
    while( scanf("%d",&n)!=EOF ){
        printf("%d\n",s[n]);
    } 
    return 0;
}

 

转载于:https://www.cnblogs.com/chenjianxiang/p/3561693.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值