ACM-ICPC2018徐州网络赛 Features Track(二维map+01滚动)

Features Track

  •  31.32%
  •  1000ms
  •  262144K
 

Morgana is learning computer vision, and he likes cats, too. One day he wants to find the cat movement from a cat video. To do this, he extracts cat features in each frame. A cat feature is a two-dimension vector <xx, yy>. If x_ixix_jxj and y_iyi = y_jyj, then <x_ixiy_iyi> <x_jxjy_jyj> are same features.

So if cat features are moving, we can think the cat is moving. If feature <aa, bb> is appeared in continuous frames, it will form features movement. For example, feature <aa , bb > is appeared in frame 2,3,4,7,82,3,4,7,8, then it forms two features movement 2-3-4234 and 7-878.

Now given the features in each frames, the number of features may be different, Morgana wants to find the longest features movement.

Input

First line contains one integer T(1 \le T \le 10)T(1T10), giving the test cases.

Then the first line of each cases contains one integer nn (number of frames),

In The next nn lines, each line contains one integer k_iki ( the number of features) and 2k_i2kiintergers describe k_iki features in ith frame.(The first two integers describe the first feature, the 33rd and 44th integer describe the second feature, and so on).

In each test case the sum number of features NN will satisfy N \le 100000N100000 .

Output

For each cases, output one line with one integers represents the longest length of features movement.

样例输入复制
1
8
2 1 1 2 2
2 1 1 1 4
2 1 1 2 2
2 2 2 1 4
0
0
1 1 1
1 1 1
样例输出复制
3
题目来源

ACM-ICPC 2018 徐州赛区网络预赛

 

 

二维map记录当前行累积pair个数,因为只涉及到当前行与上一行的状态,因此采用01滚动map即可。

 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

map<int,map<pair<int,int>,int> > mp;
pair<int,int> p;

int main()
{
    int t,n,x,y,i,j,k;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int ans=0,xxx=0;
        for(int i=0;i<n;i++){
            scanf("%d",&k);
            mp[xxx].clear();
            while(k--){
                scanf("%d%d",&x,&y);
                p = make_pair(x,y);
                if(mp[xxx^1].count(p)){
                    mp[xxx][p] = mp[xxx^1][p]+1;
                    ans=max(ans,mp[xxx][p]);
                }
                else{
                    mp[xxx][p]=1;
                    ans=max(ans,mp[xxx][p]);
                }
            }
            xxx^=1;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yzm10/p/9614228.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值