UVa 208-Firetruck

问题描述】

The Center City fire department collaborates with the transportation department to maintain maps of the city which reflects the current status of the city streets. On any given day, several streets are closed for repairs or construction. Firefighters need to be able to select routes from the firestations to fires that do not use closed streets. Central City is divided into non-overlapping fire districts, each containing a single firestation. When a fire is reported, a central dispatcher alerts the firestation of the district where the fire is located and gives a list of possible routes from the firestation to the fire. You must write a program that the central dispatcher can use to generate routes from the district firestations to the fires.

Input 

The city has a separate map for each fire district. Streetcorners of each map are identified by positive integers less than 21, with the firestation always on corner #1. The input file contains several test cases representing different fires in different districts.

  • The first line of a test case consists of a single integer which is the number of the streetcorner closest to the fire.

  • The next several lines consist of pairs of positive integers separated by blanks which are the adjacent streetcorners of open streets. (For example, if the pair 4 7 is on a line in the file, then the street between streetcorners 4 and 7 is open. There are no other streetcorners between 4 and 7 on that section of the street.)

  • The final line of each test case consists of a pair of 0's.

Output 

For each test case, your output must identify the case by number (CASE #1CASE #2, etc). It must list each route on a separate line, with the streetcorners written in the order in which they appear on the route. And it must give the total number routes from firestation to the fire. Include only routes which do not pass through any streetcorner more than once. (For obvious reasons, the fire department doesn't want its trucks driving around in circles.) Output from separate cases must appear on separate lines. The following sample input and corresponding correct output represents two test cases.

Sample Input 

6
1 2
1 3
3 4
3 5
4 6
5 6
2 3
2 4
0 0
4
2 3
3 4
5 1
1 6
7 8
8 9
2 5
5 7
3 1
1 8
4 6
6 9
0 0

Sample Output 

CASE 1:
1 2 3 4 6
1 2 3 5 6
1 2 4 3 5 6
1 2 4 6
1 3 2 4 6
1 3 4 6
1 3 5 6
There are 7 routes from the firestation to streetcorner 6.
CASE 2:
1 3 2 5 7 8 9 6 4
1 3 4
1 5 2 3 4
1 5 7 8 9 6 4
1 6 4
1 6 9 8 7 5 2 3 4
1 8 7 5 2 3 4
1 8 9 6 4
There are 8 routes from the firestation to streetcorner 4.


【解题思路

    构造出一张图,给出一个点,字典序输出所有从1到该点的路径。

    注意:裸搜会超时,其实题目的数据特地设计得让图稠密但起点和终点却不相连,所以直接搜索过去会超时。

只要判断下起点和终点能不能相连就行了,可以用并查集也可以用floyd算法。

    改进方法:先从终点出发,无回溯的走遍和终点相连的所有点并标记,然后从起点出发,DFS判断下标记,这样就不会多走很多路了。另一个方法是在把点并入并查集的时候不考虑起点,然后DFS只走和终点同一集合的点。


【具体实现

#include<iostream>

using namespace std;

/*正整数对数量最大值*/
const int maxN = 999999;
/*保存离火警最近的街区编号*/
int fireTruck;
int t = 0, v, sum;
int g[30][30], vis[30], floyd[30][30], rec[30];

/*然后从起点出发搜索,DFS判断下标记*/
void DFS(int x, int n) {
	if (x == fireTruck) {
		cout << "1";
		for (int i = 1; i < n - 1; i++)
			cout << " " << rec[i];
		cout << " " << fireTruck << endl;
		sum++;
		return;
	}
	for (int i = 1; i <= v; ++i) {
		if (!vis[i] && g[x][i] == 1 && floyd[fireTruck][i] != maxN){
			rec[n] = i;
			vis[i] = 1;
			DFS(i, n + 1);
			vis[i] = 0;
		}
	}
}

int main() {
	int x, y, cas = 1;
	/*输入离火警最近的街区编号*/
	while (cin >> fireTruck) {
		v = 0;
		for (int i = 1; i <= 21; ++i)
		for (int j = 1; j <= 21; ++j)
			g[i][j] = floyd[i][j] = maxN;
		/*输入未封闭街道连接的相邻的街区并标记*/
		while (cin >> x >> y && (x || y)) {
			g[x][y] = g[y][x] = 1;
			floyd[x][y] = floyd[y][x] = 1;
			if (x > v) v = x;
			if (y > v) v = y;
		}
		/*从终点出发,无回溯的走遍和终点相连的所有点并标记*/
		for (int k = 1; k <= v; ++k)
		for (int i = 1; i <= v; ++i)
		for (int j = 1; j <= v; ++j)
		if (floyd[i][k] + floyd[k][j] < floyd[i][j])
			floyd[i][j] = floyd[i][k] + floyd[k][j];
		vis[1] = 1;
		sum = 0;
		cout << "CASE " << cas++ << ":" << endl;
		/*从起点出发,DFS判断下标记*/
		DFS(1, 1);
		cout << "There are " << sum << 
			" routes from the firestation to streetcorner " 
			<< fireTruck << "." << endl;
	}

	return 0;
}


【额外补充

   就酱。



转载于:https://my.oschina.net/CoderBleak/blog/669723

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值