掌握路由再发布
 
路由协议的迁移
    路由协议的再分发/再发布
    再发布后默认的metric
    protocol             default seed metric
    RIP                  infinity(无穷大即不可达)  别的路由协议重分发到RIP中,如果不指定METRIC,则为INFINITY  <16
    IGRP/EIGRP           infinity(无穷大即不可达)
    OSPF                 20 for all except bgp,which is 1
    IS-IS                0
    bgp                  BGP metric is set to IGP metric value
    如何进行路由再发布
    双向重分发(容易出现问题,建议一个方向使用默认路由)
    重分发命令:
    Router(config-router)#redistribute ?
    注意:把别的路由协议重分发到OSPF协议中去的时候,必须加上SUBNET,否则只会加入主类网络。
router rip
redistribute ospf 1 metric 3    这里必须设置metric的值,否则默认为infinity,即不可达
router ospf 1
redistribute eigrp 100 subnets metric-type 1   这里必须加上SUBNET,否则只会加入主类网络  这里没有设置metric,默认为20
router eigrp 100
redistribute ospf 1 metric 10000 100 255 1 1500(带宽 延迟 负载 )
router eigrp 100
redistribute eigrp 200     这里metric可以配置,也可以不配置
router isis
redistibute eigrp 100    这里metric可以配置,也可以不配置  默认METRIC为0
 
被动接口
passive-interface
router rip
network 10.0.0.0
passive-interface s1
passive-interface default(让所有端口都设置为被动接口) 
no passive-interface s1 然后排除不是被动接口的接口
路由过滤 
distribute-list {access-list-number/name} out interfaces/route protocol
distribute-list {access-list-number/name} in interfaces

route map的应用  功能非常强大
1
2 策略路由
3 NAT
4 BGP路由策略的实现
route map 的操作
语句的处理是自上而下的
一旦找到匹配成功语句,后续匹配操作将不再进行
序列号用来指定route map
具体配置
route-map map-tag permit 10
match  剩余没有被匹配,则DENY;所以需要配置剩余
  options:
  ip address ip-access-list 调用访问控制列表
  ip route-source  ip-access-list
  ip next-hop  ip-access-list
  interface type number 
  metric metric-type 
  route-type
set
  options:
  metric
  metric-type
  level {level-1 level-2}
  ip next-hop next-hop-address

PBR配置  在接口上调用route map
优点 基于源地址的路由选择   QOS   负载分担
功能
ip policy route-map map-name 策略应该使用在进栈口
show ip policy
show route-map