ACM之路刚刚开始

其实我完全没甚么废话好说的,只是希望养成一个总结的好习惯。让自己以后思路更加清晰。

比如说下面的一道来自杭电的ACM-Steps的一道比较简单的题目,但是为甚么多次提交都是错误,可是不管怎么调试都是对的,其实是题目没有好好看。


GPA

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3580 Accepted Submission(s): 1466
 
Problem Description
Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.
 
Input
The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.
 
Output
Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.
 
Sample Input
A B C D F
B F F C C A
D C E F
 
Sample Output
2.00
1.83
Unknown letter grade in input
 
Author
2006Rocky Mountain Warmup
 
Source
HDU “Valentines Day” Open Programming Contest 2009-02-14
 
Recommend
lcy
这道题其实真的没有什么难度,但是输出格式还是要注意,尤其对于我这样的低级新手来说

The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.

这句话真的是一定要好好读清楚。

所以修正之后最后的代码应为:

#include<cstdio>

using namespace std;

int main(){	
	char rank;
	double score = 0.0;
	int cnt = 0;
	int flag2 = 1;
		while(scanf("%c",&rank) != EOF){
			if (rank == ' ')
				continue;
			if	(rank == '\n'){
				if(flag2){
					printf("%.2f\n",score/cnt);
				}else{
					printf("Unknown letter grade in input\n");
				}
				flag2 = 1;
				cnt = 0;
				score = 0;
				continue;
			}
			if(rank == 'A')
				score += 4;
			else if(rank == 'B')
				score += 3;
			else if(rank == 'C')
				score += 2;
			else if(rank == 'D')
				score += 1;
			else if(rank == 'F')
				score += 0;
			else{
				flag2 = 0;
			}
			cnt ++;
		}
	return	0;
}

嗯这是第一篇,如有兴趣的朋友,也请多指正。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值