scu Easy Problem VI SCU

Time Limit: 1000 MS Memory Limit: 131072 K

Description

In this problem you are to calculate the sum of all integers from 1 to n, but you should take all powers of two with minus in the sum.

For example, for n=4 the sum is equal to -1-2+3-4=-4, because 1, 2 and 4 are 2^0, 2^1 and 2^2 respectively.

Calculate the answer for t values of n.

Input

The first line of the input contains a single integer t (1≤t≤100) — the number of values of n to be processed.

Each of next t lines contains a single integer n (1≤n≤10^9).

Output

Print the requested sum for each of t integers n given in the input.

Sample Input

2
4
1000000000

Sample Output

-4
499999998352516354
题意:从1到n相加的和,但是遇到2^0,2^1,2^2,,,等等,要把这个数变成负数。
脑残数学毁一生,zz,就是一个数学题;
一个等差数列减去两个等比数列
等差数列指,从1加到n;
等比数列指,2^0,2^1,2^2,,,等等

#include<cstdio>
#include <cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main ()
{
    long long sum,n,t;
    int i;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld",&n);
        for(i=0;pow(2,i)<=n;i++);
        printf("%lld\n",n*(n+1)/2-2*((1<<i)-1));
    }
    return 0;
}

转载于:https://www.cnblogs.com/zxy160/p/7215143.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值