<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

 

<?xml:namespace prefix = v ns = "urn:schemas-microsoft-com:vml" />

 

R1 -----r2  s
R2-----r3  rip
R3----r4  eigrp

 

 

R1#show run
Building configuration...

 

Current configuration : 824 bytes
!
version 12.4
no service password-encryption
!
hostname R1
!
!
!
!
!
ip ssh version 1
!
!
interface Loopback0
 ip address 192.168.40.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/3
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.20.0 255.255.255.0 192.168.10.2
ip route 192.168.30.0 255.255.255.0 192.168.20.2
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
End

 

R2#show run
Building configuration...

 

Current configuration : 784 bytes
!
version 12.4
no service password-encryption
!
hostname R2
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 ip address 192.168.10.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/0
 ip address 192.168.20.1 255.255.255.0
 duplex auto
 speed auto
!
interface Ethernet1/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/3
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 network 192.168.10.0
 network 192.168.20.0
!
ip classless
ip route 192.168.40.0 255.255.255.0 192.168.10.1
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
End

 

 

R3#show run
Building configuration...

 

Current configuration : 810 bytes
!
version 12.4
no service password-encryption
!
hostname R3
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/0
 ip address 192.168.20.2 255.255.255.0
 duplex auto
 speed auto
!
interface Ethernet1/1
 ip address 192.168.30.1 255.255.255.0
 duplex auto
 speed auto
!
interface Ethernet1/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/3
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 192.168.20.0
 network 192.168.30.0
 auto-summary
!
router rip
 network 192.168.20.0
 network 192.168.30.0
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
End

 

R4#show run
Building configuration...

 

Current configuration : 767 bytes
!
version 12.4
no service password-encryption
!
hostname R4
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/0
 ip address 192.168.30.2 255.255.255.0
 duplex auto
 speed auto
!
interface Ethernet1/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Ethernet1/3
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 192.168.30.0
 auto-summary
!
ip classless
ip route 192.168.10.0 255.255.255.0 192.168.20.1
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end