数据结构练习 02-线性结构1. 一元多项式求导 (25)

设计函数求一元多项式的导数。(注:xn(n为整数)的一阶导数为n*xn-1。)

输入格式:以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是0,但是表示为“0 0”。

输入样例:

3 4 -5 2 6 1 -2 0
输出样例:
12 3 -10 1 6 0
 
#include<iostream>
#include<string>
using namespace std;
typedef struct Lnode{
    int coe;
    int index;
    struct Lnode *next;
}pol;
int main(){
    int coe,index,n=0;
    pol *head=new pol;
    pol *p=new pol,*q;
    head->next=p;
     while(cin>>coe>>index) 
    {
        
        p->coe=coe;
        p->index=index;
        n++;
        q=p;
        p= new pol;
        q->next=p;
    } 
    q->next=NULL;
    delete p;
    p=head->next;
    while(p!=NULL){
        p->coe=p->coe*p->index;
        if(p->index!=0)
            p->index=p->index-1;
        p=p->next;
    }
    p=head->next;
    while(p!=NULL){
        if(p->next!=NULL && p->index==0 && p->next->index==0){
            q=p->next;
            p->next=q->next;
            delete q;
        }
        if(p->next!=NULL &&  p->next->coe==0){
            q=p->next;
            p->next=q->next;
            delete q;
        }
        p=p->next;
    }
    p=head->next;
    while(p!=NULL){
        cout<<p->coe<<" "<<p->index;
        if(p->next!=NULL){
            cout<<" ";
        }
        p=p->next;
    }
    return 0;
}

image

经过19次提交,总算是成功了。读懂题很重要啊

转载于:https://www.cnblogs.com/Zengineer/p/4377588.html

  • 0
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值