POJ 1328 Radar Installation

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar InstallationsInput
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1

分析:对小岛与海岸线的交点按从左到右的次序排序,排序完成后,第一个雷达建立在第一个区间的右端,然后判断每个区间的左端点,如果在最新建立的雷达右面,那么肯定需要一个雷达,而且也建在区间右端。如果左端点在雷达左面,这个时候要考虑区间的右端在雷达的左面还是右面,如果是右面,那雷达位置就不变,如果在左面,那现在的雷达是覆盖不了的,所以要把雷达放在该区间的右端点!因为这样同时还能覆盖原来的岛,还能覆盖现在的岛!

code:

View Code
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
struct di
{
double l;
double r;
}q[1001];
int cmp(const void*p1,const void*p2)
{
struct di *c=(struct di*)p1;
struct di *d=(struct di*)p2;
return c->l>=d->l?1:-1;
}
int main()
{
int tot,n,i,c=1,flag;
double r,x,y,be;
while(scanf("%d%lf",&n,&r),n||r)
{
flag=0;
for(i=0;i<n;i++){
scanf("%lf%lf",&x,&y);
if(fabs(y)>r)
flag=1;
q[i].l=x-sqrt(pow(r,2)-pow(y,2));
q[i].r=x+sqrt(pow(r,2)-pow(y,2));
}
qsort(q,n,sizeof(q[0]),cmp);
tot=1;
be=q[0].r;
for(i=1;i<n;i++)
{
if(q[i].l>be)
{
tot++;
be=q[i].r;
}
else if(q[i].r<be)
be=q[i].r;
}
if(flag)
printf("Case %d: -1\n",c++);
else
printf("Case %d: %d\n",c++,tot);
}
return 0;
}


转载于:https://www.cnblogs.com/dream-wind/archive/2012/03/16/2400625.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值