hdoj1004(查找众多字符串中个数最多的字符串)

Let the Balloon Rise.

最近开始刷hdoj,想通过写博客做做笔记,记录写过代码。

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0

Sample Output

red

pink

分析:

本题的目的是将众多字符串中的出现个数最多的字符串找到并输出。

1.在用c/c++编写的时候,可以使用字符型的二维数组存字符串。数组一般声明得稍大些。

2.思路是计算每一个字符串s[j]后面的与s[j]相同的字符串的个数a[j],若a[j]>max,则max=a[j];flag=j,最后flag中存储的就是个数最多的字符串第一次出现的下标。

3.用int strcmp(char[],char[])==0?来判断字符串是否相同。

下面是AC代码:

#include<stdio.h>
#include<string.h>
#define maxn 1005     //N<=1000,数组一般声明得稍大些,所以我设1005
int main(){
	int n,flag,max;    //max用来存当前颜色最多的字符串个数,flag存其下标
	int a[maxn];       //用来存放每个字符串后面的与其相同的字符串个数
	char s[maxn][16];
	while(scanf("%d",&n)!=EOF&&n){     
		max=0;
		flag=0;
		for(int i=0;i<n;i++)    //输入字符串
			scanf("%s",s[i]);
		for(int j=0;j<n;j++){    //比较两个字符串,如果相同,则对应a[j]++
			a[j]=0;
			for(int k=j+1;k<n;k++)    
				if(strcmp(s[j],s[k])==0)
					a[j]++;
			if(a[j]>max){
				max=a[j];
				flag=j;
			}
		}
		printf("%s\n",s[flag]);    //输出最大个数的字符串
	}
	return 0;
}

最后,我有个疑问,就是假如输入的字符串个数最多的不止一种,该怎么办?例如

red

pink

black

red

pink

我的处理方法是输出先达到max的字符串,也就是靠前的,即“red"。

 

转载于:https://www.cnblogs.com/FrankChen831X/p/10326097.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值