思维体操: HDU1008 Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 73602    Accepted Submission(s): 40513


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
 
  
1 2 3 2 3 1 0
 

Sample Output
 
  
17 41
 

Author
ZHENG, Jianqiang
Problem : 1008 ( Elevator )     Judge Status : Accepted
RunId : 21242476    Language : G++    Author : hnustwanghe
Code Render Status : Rendered By HDOJ G++ Code Render Version 0.01 Beta
#include<iostream> #include<cstring> #include<cstdio> using namespace std; int main(){ int n,ans,last,now,i; while(scanf("%d",&n)==1 &&n){ for(ans = last = 0,i=0;i<n;i++){ scanf("%d",&now); if(now - last > 0){ ans += (now - last) * 6; last = now; } else if(now - last < 0){ ans += (last - now) * 4; last = now; } } ans = ans + n*5; printf("%d\n",ans); } }
#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

int main(){
    int n,ans,last,now,i;
    while(scanf("%d",&n)==1 &&n){
        for(ans = last = 0,i=0;i<n;i++){
            scanf("%d",&now);
            if(now - last > 0){
                ans += (now - last) * 6;
                last = now;
            }
            else if(now - last < 0){
                ans += (last - now) * 4;
                last = now;
            }
        }
        ans = ans + n*5;
        printf("%d\n",ans);
    }
}

转载于:https://www.cnblogs.com/Pretty9/p/7347703.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值