A Spy in the Metro UVA 1025 DP

A - A Spy in the Metro
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated.

Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria.

The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.

\epsfbox{p2728.eps}

Input 

The input file contains several test cases. Each test case consists of seven lines with information as follows.
Line 1.
The integer  N (  2$ \le$N$ \le$50), which is the number of stations.
Line 2.
The integer  T (  0$ \le$T$ \le$200), which is the time of the appointment.
Line 3.
N - 1 integers:  t1t2,..., tN - 1 (  1$ \le$ti$ \le$70), representing the travel times for the trains between two consecutive stations:  t1represents the travel time between the first two stations,  t2 the time between the second and the third station, and so on.
Line 4.
The integer  M1 (  1$ \le$M1$ \le$50), representing the number of trains departing from the first station.
Line 5.
M1 integers:  d1d2,..., dM1 (  0$ \le$di$ \le$250 and  di < di + 1), representing the times at which trains depart from the first station.
Line 6.
The integer  M2 (  1$ \le$M2$ \le$50), representing the number of trains departing from the  N-th station.
Line 7.
M2 integers:  e1e2,..., eM2 (  0$ \le$ei$ \le$250 and  ei < ei + 1) representing the times at which trains depart from the  N-th station.

The last case is followed by a line containing a single zero.

Output 

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word `  impossible' in case Maria is unable to make the appointment. Use the format of the sample output.

Sample Input 

4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0

Sample Output 

Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible

题意:n个车站,从左到右编号1到n;有M1辆车从1站出发向右开,M2辆车从n站 向左开。在时刻0,人从第一站出发,目的是在时刻T会见车站n的一个间谍。在车站等车容易被抓,人 应该尽量躲在开动的火车上,让等车的总时间尽量小。输入第一行为n,第二行为T,第三行有n-1个整数t1,t2.。。。tn-1,其中ti表示火车从i站到i+1站的行驶时间(两个方向一样)。第四行为M1,第五行有M1个整数d1,d2,,dM1,即各列车出发的时间;6,7行同4,5行。

分析:时间是单调流逝的,是一个天然的“序”。影响到决策的只有当前时间和所处的车站,所以可以用d(i,j)表示在时刻i,你在车站j,最少还需要等待多长时间。边界条件是d(T,n)=0;其他d(T,i)=INF。有如下3中决策:

(1)等待一分钟;

(2)搭乘向右开的车(如果有的话);

(3)搭乘向左开的车(如果有的话)。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int dp[250][60],have_train[250][60][2],t[100];
//have_train[i][j][0]记录在i时刻,在j站是否有火车向右开,同理have_train[i][j][1]则记录向右的

int main()
{
    int i,j,T,n,M1,M2,cas=1;
    while (scanf("%d",&n)&&n)
    {
        memset(t,0,sizeof(t));
        memset(have_train,0,sizeof(have_train));
        scanf("%d",&T);
        for (i=1;i<n;i++)
            scanf("%d",&t[i]);
        scanf("%d",&M1);
        int tt;
        for (i=0;i<M1;i++)
        {
            scanf("%d",&tt);
            for (j=1;j<n;j++)
            {
                tt+=t[j-1];
                have_train[tt][j][0]=1;   //标记所有 有向右开的火车 的时刻和站台
            }
        }
        scanf("%d",&M2);
        for (i=0;i<M2;i++)
        {
            scanf("%d",&tt);
            for (j=n;j>0;j--)
            {
                tt+=t[j];
                have_train[tt][j][1]=1;  //标记所有 有向左开的火车 的时刻和站台
            }
        }
        for (i=1;i<=n-1;i++)
            dp[T][i]=INF;
        dp[T][n]=0;
        for (i=T-1;i>=0;i--)
            for (j=1;j<=n;j++)
            {
                dp[i][j]=dp[i+1][j]+1;  //等待一分钟
                if (j<n&&have_train[i][j][0]&&i+t[j]<=T)
                    dp[i][j]=min(dp[i][j],dp[i+t[j]][j+1]);  //向右
                if (j>1&&have_train[i][j][1]&&i+t[j-1]<=T)
                    dp[i][j]=min(dp[i][j],dp[i+t[j-1]][j-1]);  //向左
            }
        printf("Case Number %d:",cas++);
        if (dp[0][1]>=INF)
            printf(" impossible\n");
        else
            printf(" %d\n",dp[0][1]);
    }
    return 0;
}


转载于:https://www.cnblogs.com/i8888/p/4044025.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值