image

R1#sh run
Building configuration...

Current configuration : 1271 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto keyring Keyring
  pre-shared-key address 121.233.1.2 key cisco
!
crypto isakmp policy 10
hash md5
authentication pre-share
crypto isakmp profile IsaProfile
! This profile is incomplete (no match identity statement)
   keyring Keyring
crypto isakmp profile Isaprofile
   match identity address 121.233.1.2 255.255.255.255
!
!
crypto ipsec transform-set Trans esp-des esp-md5-hmac
!
crypto map MAP 10 ipsec-isakmp
set peer 121.233.1.2
set transform-set Trans
set isakmp-profile IsaProfile
match address ×××
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 121.233.1.1 255.255.255.0
duplex auto
speed auto
crypto map MAP
!
no ip http server
no ip http secure-server
ip route 2.2.2.0 255.255.255.0 121.233.1.2
!
!
!
!
ip access-list extended ×××
permit ip 1.1.1.0 0.0.0.255 2.2.2.0 0.0.0.255
!
!
!
control-plane
!
!
!
!
!
!
!        
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

R1#  

========================================================================

R2#sh run
Building configuration...

Current configuration : 1179 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto keyring Keyring
  pre-shared-key address 121.233.1.1 key cisco
!
crypto isakmp policy 10
hash md5
authentication pre-share
crypto isakmp profile IsaProfile
   keyring Keyring
   match identity address 121.233.1.1 255.255.255.255
!
!
crypto ipsec transform-set Trans esp-des esp-md5-hmac
!
crypto map MAP 10 ipsec-isakmp
set peer 121.233.1.1
set transform-set Trans
set isakmp-profile IsaProfile
match address ×××
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 121.233.1.2 255.255.255.0
duplex auto
speed auto
crypto map MAP
!
no ip http server
no ip http secure-server
ip route 1.1.1.0 255.255.255.0 121.233.1.1
!
!
!
!
ip access-list extended ×××
permit ip 2.2.2.0 0.0.0.255 1.1.1.0 0.0.0.255
!
!
!
control-plane
!
!
!
!
!
!
!
!
!        
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

R2#