Poj(1459),最大流,EK算法

题目链接:http://poj.org/problem?id=1459

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 27074 Accepted: 14066

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

Source

题意:给几个发电站,给几个消耗站,再给几个转发点。发电站只发电,消耗站只消耗电,转发点只是转发电,再给各个传送线的传电能力。问你消耗站能获得的最多电是多少。
分析:加一个超级源点,和一个超级汇点。
这个题之前做过。记录一下EK的思想吧。
EK:
广搜每一层节点,每次都记录增广路上的最小流量,汇点的最小流量为0时,说明没有增广路了。根据汇点的最小流量,更新流。
有一点要注意的是,搜索第一层后,记得标记,再往下一层搜,一直搜到汇点为止,但是我这里好像是没有标记,其实标记了,node[i]没有标记为0.
输入有空格。
#include <stdio.h>
#include <string.h>
#include <queue>
#include <iostream>

using namespace std;

#define MAX 120
#define INF 0x3f3f3f3f

int n,np,nc,m;
int cap[MAX][MAX];


int main()
{
    //freopen("input.txt","r",stdin);
    int from,to,value;
    while(scanf("%d%d%d%d",&n,&np,&nc,&m)!=EOF)
    {

        memset(cap,0,sizeof(cap));

        ///读取输电线的数据
        while(m--)
        {
            scanf(" (%d,%d)%d",&from,&to,&value);
            cap[from][to]=value;
        }

        ///读取发电站数据
        while(np--)
        {
            scanf(" (%d)%d",&from,&value);
            cap[n][from]=value;
        }

        ///读取消费者数据
        while(nc--)
        {
            scanf(" (%d)%d",&from,&value);
            cap[from][n+1]=value;
        }

        int ans = 0;
        queue<int>  Q;
        int flow[MAX][MAX];     ///剩余网络
        int node[MAX];          ///最小流
        int pre[MAX];           ///增广路径


        memset(flow,0,sizeof(flow));

        while(true)
        {
            Q.push(n);
            memset(node,0,sizeof(node));
            node[n] = INF;
            int u;
            while(!Q.empty())
            {
                u = Q.front();
                Q.pop();
                for(int i=0; i<=n+1; i++)
                {
                    if(!node[i]&&cap[u][i]>flow[u][i])
                    {
                        Q.push(i);
                        node[i] = min(node[u],cap[u][i]-flow[u][i]);
                        pre[i] = u;
                    }
                }
            }

            if(node[n+1]==0)
                break;

            for(u=n+1; u!=n; u=pre[u])
            {
                flow[pre[u]][u] +=node[n+1];
                flow[u][pre[u]] -= node[n+1];
            }

            ans+=node[n+1];

        }
        printf("%d\n",ans);
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/TreeDream/p/5752109.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值