<?xml:namespace prefix = v ns = "urn:schemas-microsoft-com:vml" /><?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

 

 

实验任务和目标:

任务 1. 按照实验要求连接拓扑

任务 2. 配置 ROUTER1 ROUTER2 之间的 PPP CHAP 认证

任务 3. 配置 ROUTER2 ROUTER3 之间的 PPP 及多链路

任务 4. 配置 ROUTER2 ROUTER3 之间的 PAP 认证【双向】

 

   

 

Router1 F1/0 <----> VPCS V0/1
Router1 S0/1 <----> Router2 S0/3
Router2 S0/1 <----> Router3 S0/1
Router2 S0/2 <----> Router3 S0/2
Router3 F1/0 <----> VPCS V0/2

 

 

 

R1  R2  R3

enable
config t
no ip domain-lookup
line console 0
no exec-timeout
logg sy
exit
hostname r

 

PPP 配置

 

R2为主认证

 

 

R1:被认证

 

 

 

R2-----------R1 CHAP 认证

R2:

r2(config)#interface s0/3
r2(config-if)#config t
r2(config-if)#encapsulation ppp
r2(config-if)#ppp authentication chap
r2(config-if)#
*Mar  1 00:16:27.547: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/3, changed state to down
r2(config-if)#ppp chap hostname lisi
r2(config-if)#no shutdown
r2(config-if)#exit
r2(config)#
*Mar  1 00:18:46.675: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/3, changed state to up

 

r2#show ip int  
r2#show ip interface bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  unassigned      YES unset  administratively down down   
Serial0/1                  unassigned      YES unset  administratively down down   
Serial0/2                  unassigned      YES unset  administratively down down   
Serial0/3                  192.168.1.2     YES manual up                    up     
FastEthernet1/0            unassigned      YES unset  up                    down   
FastEthernet1/1            unassigned      YES unset  up                    down   
FastEthernet1/2            unassigned      YES unset  up                    down   
FastEthernet1/3            unassigned      YES unset  up                    down   
FastEthernet1/4            unassigned      YES unset  up                    down   
FastEthernet1/5            unassigned      YES unset  up                    down   
FastEthernet1/6            unassigned      YES unset  up                    down   
 --More--

 

 

R1:

r1(config)#interface s0/1
r1(config-if)#encapsulation ppp
r1(config-if)#exit
r1(config)#username lisi password 123
r1(config)#interface s0/1
r1(config-if)#encapsulation ppp
r1(config-if)#ppp chap hostname  benet
r1(config-if)#exit
r1(config)#
*Mar  1 00:18:43.375: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

 

 

r1#show ip interface bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  unassigned      YES manual administratively down down   
Serial0/1                  192.168.1.1     YES manual up                    up     
Serial0/2                  unassigned      YES unset  administratively down down   
Serial0/3                  unassigned      YES unset  administratively down down   
FastEthernet1/0            unassigned      YES unset  up                    up     
FastEthernet1/1            unassigned      YES unset  up                    down   
FastEthernet1/2            unassigned      YES unset  up                    down   
FastEthernet1/3            unassigned      YES unset  up                    down   
FastEthernet1/4            unassigned      YES unset  up                    down   
FastEthernet1/5            unassigned      YES unset  up                    down   
FastEthernet1/6            unassigned      YES unset  up                    down   
FastEthernet1/7            unassigned      YES unset  up                    down   
FastEthernet1/8            unassigned      YES unset  up                    down   
FastEthernet1/9            unassigned      YES unset  up                    down   
FastEthernet1/10           unassigned      YES unset  up                    down   
FastEthernet1/11           unassigned      YES unset  up                    down   
FastEthernet1/12           unassigned      YES unset  up                    down   
FastEthernet1/13           unassigned      YES unset  up                    down   
FastEthernet1/14           unassigned      YES unset  up                    down   
FastEthernet1/15           unassigned      YES unset  up                    down   
Vlan1                      unassigned      YES unset  up                    up     
r1#

 

 

 

 

 

 

R2---------R3   

R2:

创建多链路

r2(config)#interface multilink 1

*Mar  1 00:26:39.075: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to down

r2(config-if)#ip address 192.168.2.1 255.255.255.0

r2(config-if)#encapsulation ppp

r2(config-if)#clock rate 64000

r2(config-if)#ppp multilink group 1

r2(config-if)#no shutdown

r2(config-if)#exit

r2(config)#interface s0/1

r2(config-if)#encapsulation ppp

r2(config-if)#ppp multilink group 1

r2(config-if)#no shutdown

r2(config-if)#exit

r2(config)#interface s0/2

r2(config-if)#

*Mar  1 00:29:23.987: %LINK-3-UPDOWN: Interface Serial0/1, changed state to up

r2(config-if)#encapsulation ppp

r2(config-if)#ppp multilink group 1

r2(config-if)#no shutdown

r2(config-if)#

*Mar  1 00:29:38.015: %LINK-3-UPDOWN: Interface Serial0/2, changed state to up

r2(config-if)#

*Mar  1 00:31:03.775: %LINK-3-UPDOWN: Interface Multilink1, changed state to up

r2(config-if)#

*Mar  1 00:31:04.763: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

*Mar  1 00:31:04.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to up

r2(config-if)#

*Mar  1 00:31:25.487: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2, changed state to up

 

 

R3

r3(config)#interface multilink 1

*Mar  1 00:30:09.695: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to down

r3(config-if)#ip address 192.168.2.2 255.255.255.0

r3(config-if)#encapsulation ppp

r3(config-if)#clock rate 64000

r3(config-if)#ppp multilink group 1

r3(config-if)#no shutdown

r3(config-if)#exit

r3(config)#interface s0/1

r3(config-if)#encapsulation ppp

r3(config-if)#ppp multilink group 1

r3(config-if)#no shutdown

r3(config-if)#exit

*Mar  1 00:31:18.779: %LINK-3-UPDOWN: Interface Serial0/1, changed state to up

*Mar  1 00:31:18.943: %LINK-3-UPDOWN: Interface Multilink1, changed state to up

*Mar  1 00:31:19.935: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

*Mar  1 00:31:19.943: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to up

r3(config)#interface s0/2

r3(config-if)#encapsulation ppp

r3(config-if)#ppp multilink group 1

r3(config-if)#no shutdown

*Mar  1 00:31:39.599: %LINK-3-UPDOWN: Interface Serial0/2, changed state to up

r3(config-if)#

*Mar  1 00:31:40.607: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2, changed state to up

 

单向 PAP

R2;

r2#config terminal

Enter configuration commands, one per line.  End with CNTL/Z.

r2(config)#interface multilink 1

r2(config-if)#ppp authentication pap

*Mar  1 00:45:01.851: %LINK-3-UPDOWN: Interface Multilink1, changed state to down

*Mar  1 00:45:02.823: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to down

*Mar  1 00:45:02.831: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2, changed state to down

*Mar  1 00:45:02.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to down

r2(config-if)#exit

r2(config)#

*Mar  1 00:45:38.615: %LINK-3-UPDOWN: Interface Multilink1, changed state to up

*Mar  1 00:45:39.615: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to up

r2(config)#

*Mar  1 00:45:39.731: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

*Mar  1 00:45:39.751: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2, changed state to up

r2(config)#

R3:

 

r3#config t

Enter configuration commands, one per line.  End with CNTL/Z.

r3(config)#interface multilink 1

r3(config-if)#ppp pap sent-username benet password 123

r3(config-if)#exit

r3(config)#

*Mar  1 00:45:53.823: %LINK-3-UPDOWN: Interface Multilink1, changed state to up

r3(config)#

*Mar  1 00:45:54.811: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

*Mar  1 00:45:54.823: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to up

*Mar  1 00:45:55.179: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2, changed state to up

r3(config)#

 

 

PAP 双向

R2:

r2#config terminal

Enter configuration commands, one per line.  End with CNTL/Z.

r2(config)#interface multilink 1

r2(config-if)#ppp pap sent-username be password 123

r2(config-if)#exit

 

 

 

R3:

r3(config)#username be password 123

r3(config)#exit

r3#

*Mar  1 00:50:25.819: %SYS-5-CONFIG_I: Configured from console by console

r3#

 

 

 

 

 

 

 

R1--------------R3      PING

R2:

r2(config)#router rip

r2(config-router)#version 2

r2(config-router)#auto-summary

r2(config-router)#network 192.168.1.0

r2(config-router)#network 192.168.2.0

R1:

r1(config)#router rip

r1(config-router)#version 2

r1(config-router)#auto-summary

r1(config-router)#network 192.168.1.0

R3:

r3(config)#router rip

r3(config-router)#version 2

r3(config-router)#auto-summary

r3(config-router)#network 192.168.2.0

r3(config-router)#end

r3#

 

 

 

 

 

 

R1 ----------R3

r1(config)#router rip

r1(config-router)#version 2

r1(config-router)#auto-summary

r1(config-router)#network 192.168.3.0

r3(config)#router rip

r3(config-router)#version 2

r3(config-router)#auto-summary

r3(config-router)#network 192.168.4.0