1. Configure OSPF area 0 on the frame-relay interfaces between R1, R2, R3 and R5.
2. Put R1’s ethernet 0 in area 1
3. Put R2’s ethernet 0 in area 10
4. Put R3’s serial 1 and all of R4 in area 3
5. Put R5’s ethernet 0 in area 4.
6. Create two loopback interfaces on R4 and put both of the associated subnets on R4 in area 44.
7. Summarize the 2-loopback subnets so they appear as one route to the rest of the OSPF routers.
8. Here is tricky part; You can’t use the command ip ospf network anywhere in your
configurations.
9. As stated before you should be able to ping every interface from any router.
10. Redistribute the default route on R2 as type-1 with a metric of 100.
 
R1
conf t
int f 0/0
ip ad 10.1.1.1 255.255.0.0
no shut
int s 2/0
encap f
no arp f
no frame inver
no shut
int s2/0.1 multipoint
no arp f
no frame inver
ip ad 10.10.1.1 255.255.0.0
frame map ip 10.10.1.2 102 b
frame map ip 10.10.1.3 103 b
frame map ip 10.10.1.5 105 b
ip ospf priority 255
exit
router ospf 1
net 10.1.1.1 0.0.0.0 a 1
nei 10.10.1.2
nei 10.10.1.3
nei 10.10.1.5
net 10.10.1.1 0.0.0.0 a 0
end
 
 
R2
conf t
int f 0/0
ip ad 137.20.20.1 255.255.255.0
no shut
int s 2/0
ip ad 10.10.1.2 255.255.0.0
encap f
no arp f
no frame inver
frame map ip 10.10.1.1 201 b
frame map ip 10.10.1.3 201 b
frame map ip 10.10.1.5 201 b
ip ospf priority 0
no shut
exit
ip route 0.0.0.0 0.0.0.0 137.20.20.2
router ospf 1
nei 10.10.1.1
net 10.10.1.2 0.0.0.0 a 0
net 137.20.20.1 0.0.0.0 a 10
end
 
 
R3
conf t
int l 0
ip ad 3.3.3.3 255.255.255.255
int s2/0
ip ad 10.10.1.3 255.255.0.0
encap f
no arp f
no frame inver
frame map ip 10.10.1.1 301 b
frame map ip 10.10.1.2 301 b
frame map ip 10.10.1.5 301 b
no shut
ip ospf priority 0
int s 2/1
ip ad 10.34.1.1 255.255.0.0
encap f
no arp f
no frame inver
frame map ip 10.34.1.2 314 b
no shut
router ospf 1
router-id 3.3.3.3
nei 10.34.1.2
nei 10.10.1.1
net 10.10.1.3 0.0.0.0 a 0
net 10.34.1.1 0.0.0.0 a 3
area 3 virtual-link 4.4.4.4
end
 
R4
conf t
int l 0
ip ad 10.44.1.1 255.255.255.0
int l 1
ip ad 10.44.2.1 255.255.255.0
int l 2
ip ad 4.4.4.4 255.255.255.255
int f 0/0
ip ad 10.4.1.1 255.255.0.0
no shut
int s 2/1
ip ad 10.34.1.2 255.255.0.0
encap f
no arp f
no frame inver
frame map ip 10.34.1.1 413 b
ip ospf priority 0
no shut
router ospf 1
router-id 4.4.4.4
nei 10.34.1.1
net 10.34.1.2 0.0.0.0 a 3
net 10.4.1.1 0.0.0.0 a 3
net 10.44.1.1 0.0.0.0 a 44
net 10.44.2.1 0.0.0.0 a 44
area 3 virtual-link 3.3.3.3
end
 
 
R5
conf t
int f 0/0
ip ad 11.1.1.5 255.255.0.0
no shut
int s 2/0
ip ad 10.10.1.5 255.255.0.0
encap f
no arp f
no frame inver
frame map ip 10.10.1.1 501 b
frame map ip 10.10.1.2 501 b
frame map ip 10.10.1.3 501 b
ip ospf priority 0
no shut
router ospf 1
nei 10.10.1.1
net 10.10.1.5 0.0.0.0 a 0
net 11.1.1.5 0.0.0.0 a 4
end
 
校验
R1#sh ip ospf n
Neighbor ID     Pri   State           Dead Time   Address         Interface
137.20.20.1       0   FULL/DROTHER    00:01:58    10.10.1.2       Serial2/0.1
3.3.3.3           0   FULL/DROTHER    00:01:33    10.10.1.3       Serial2/0.1
11.1.1.5          0   FULL/DROTHER    00:01:42    10.10.1.5       Serial2/0.1
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     137.20.0.0/24 is subnetted, 1 subnets
O IA    137.20.20.0 [110/65] via 10.10.1.2, 00:01:52, Serial2/0.1
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.10.0.0/16 is directly connected, Serial2/0.1
C       10.1.0.0/16 is directly connected, FastEthernet0/0
O IA    10.4.0.0/16 [110/129] via 10.10.1.3, 00:01:52, Serial2/0.1
O IA    10.44.0.0/22 [110/129] via 10.10.1.3, 00:01:52, Serial2/0.1
O IA    10.34.0.0/16 [110/128] via 10.10.1.3, 00:01:52, Serial2/0.1
     11.0.0.0/16 is subnetted, 1 subnets
O IA    11.1.0.0 [110/65] via 10.10.1.5, 00:01:52, Serial2/0.1

R2#sh ip ospf n
Neighbor ID     Pri   State           Dead Time   Address         Interface
10.1.1.1        255   FULL/DR         00:01:59    10.10.1.1       Serial2/0
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 137.20.20.2 to network 0.0.0.0
     137.20.0.0/24 is subnetted, 1 subnets
C       137.20.20.0 is directly connected, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.10.0.0/16 is directly connected, Serial2/0
O IA    10.1.0.0/16 [110/65] via 10.10.1.1, 00:01:44, Serial2/0
O IA    10.4.0.0/16 [110/129] via 10.10.1.3, 00:01:44, Serial2/0
O IA    10.44.0.0/22 [110/129] via 10.10.1.3, 00:01:44, Serial2/0
O IA    10.34.0.0/16 [110/128] via 10.10.1.3, 00:01:44, Serial2/0
     11.0.0.0/16 is subnetted, 1 subnets
O IA    11.1.0.0 [110/65] via 10.10.1.5, 00:01:44, Serial2/0
S*   0.0.0.0/0 [1/0] via 137.20.20.2

R3#sh ip ospf n
Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4           0   FULL/  -           -        10.34.1.2       OSPF_VL0
10.1.1.1        255   FULL/DR         00:01:53    10.10.1.1       Serial2/0
4.4.4.4           0   FULL/DROTHER    00:01:58    10.34.1.2       Serial2/1
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     137.20.0.0/24 is subnetted, 1 subnets
O IA    137.20.20.0 [110/65] via 10.10.1.2, 00:01:57, Serial2/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.10.0.0/16 is directly connected, Serial2/0
O IA    10.1.0.0/16 [110/65] via 10.10.1.1, 00:01:57, Serial2/0
O       10.4.0.0/16 [110/65] via 10.34.1.2, 00:02:07, Serial2/1
O IA    10.44.0.0/22 [110/65] via 10.34.1.2, 00:01:57, Serial2/1
C       10.34.0.0/16 is directly connected, Serial2/1
     11.0.0.0/16 is subnetted, 1 subnets
O IA    11.1.0.0 [110/65] via 10.10.1.5, 00:01:57, Serial2/0

R4#sh ip ospf n
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -           -        10.34.1.1       OSPF_VL0
3.3.3.3           1   FULL/DR         00:01:55    10.34.1.1       Serial2/1
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     137.20.0.0/24 is subnetted, 1 subnets
O IA    137.20.20.0 [110/129] via 10.34.1.1, 00:01:59, Serial2/1
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback2
     10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
O       10.10.0.0/16 [110/128] via 10.34.1.1, 00:01:59, Serial2/1
O IA    10.1.0.0/16 [110/129] via 10.34.1.1, 00:01:59, Serial2/1
C       10.4.0.0/16 is directly connected, FastEthernet0/0
C       10.44.2.0/24 is directly connected, Loopback1
O       10.44.0.0/22 is a summary, 00:02:19, Null0
C       10.44.1.0/24 is directly connected, Loopback0
C       10.34.0.0/16 is directly connected, Serial2/1
     11.0.0.0/16 is subnetted, 1 subnets
O IA    11.1.0.0 [110/129] via 10.34.1.1, 00:02:00, Serial2/1

R5#sh ip ospf n
Neighbor ID     Pri   State           Dead Time   Address         Interface
10.1.1.1        255   FULL/DR         00:01:40    10.10.1.1       Serial2/0
R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     137.20.0.0/24 is subnetted, 1 subnets
O IA    137.20.20.0 [110/65] via 10.10.1.2, 00:02:10, Serial2/0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.10.0.0/16 is directly connected, Serial2/0
O IA    10.1.0.0/16 [110/65] via 10.10.1.1, 00:02:10, Serial2/0
O IA    10.4.0.0/16 [110/129] via 10.10.1.3, 00:02:10, Serial2/0
O IA    10.44.0.0/22 [110/129] via 10.10.1.3, 00:02:10, Serial2/0
O IA    10.34.0.0/16 [110/128] via 10.10.1.3, 00:02:10, Serial2/0
     11.0.0.0/16 is subnetted, 1 subnets
C       11.1.0.0 is directly connected, FastEthernet0/0