1110 Complete Binary Tree

1110 Complete Binary Tree (25)(25 分)
Given a tree, you are supposed to tell if it is a complete binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.
Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:
NO 1
 
题意:
给出树中每个结点的孩子结点(若无孩子,用-表示),要求判断其是否为完全二叉树。若是,输出YES及最后一个结点;若不是,输出NO和根结点。
 
思路:
利用层序遍历,把树的所有结点( 包括空结点)都push进队列。设立全局变量cnt,初始化cnt=0,用来记录已经访问到的 非空结点的个数,在遇到第一个空结点时,若cnt==n,则是完全二叉树;若cnt<n,则不是完全二叉树。
 
如下图,该图为完全二叉树,则在队列中元素的存储是这样的:
null(4r) null(4l) null(3r) null(3l) null(2r) 4 3 2 1
而对于如下这棵树,不是完全二叉树,则在队列中元素的存储是这样的:
null(4r) null(4l)  4 null(3l) null(2r) null(2l) 3 2 1
 
代码:
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
using namespace std;

struct Node{
    int left,right;
}Tree[25];
int n;

bool isCBT(int root,int &lastval)
{
    int cnt=0;
    queue<int> q;
    q.push(root);
    while(!q.empty()){
        int top=q.front();
        q.pop();
        if(top!=-1){
            cnt++;
            lastval=top;
            q.push(Tree[top].left);
            q.push(Tree[top].right);
        }else {
            if(cnt==n) return true;
            else return false;
        }
    }
}

int main()
{
    scanf("%d",&n);
    char v[5],u[5];
    int left,right;
    bool isRoot[25];
    memset(isRoot,true,sizeof(isRoot));
    for(int i=0;i<n;i++){
        scanf("%s %s",v,u);
        if(v[0]=='-') left=-1;
        else{
            left=atoi(v);
            isRoot[left]=false;
        }
        if(u[0]=='-') right=-1;
        else{
            right=atoi(u);
            isRoot[right]=false;
        }
        Tree[i].left=left;
        Tree[i].right=right;
    }
    int root=0;
    while(isRoot[root]==false) root++;
    int lastVal=-1;
    bool flag=isCBT(root,lastVal);
    if(flag) printf("YES %d\n",lastVal);
    else printf("NO %d\n",root);
    return 0;
}

 

 

转载于:https://www.cnblogs.com/kkmjy/p/9527832.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值