POJ 2117 Electricity (割点)

Electricity
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 2515 Accepted: 839

Description

Blackouts and Dark Nights (also known as ACM++) is a company that provides electricity. The company owns several power plants, each of them supplying a small area that surrounds it. This organization brings a lot of problems - it often happens that there is not enough power in one area, while there is a large surplus in the rest of the country. 

ACM++ has therefore decided to connect the networks of some of the plants together. At least in the first stage, there is no need to connect all plants to a single network, but on the other hand it may pay up to create redundant connections on critical places - i.e. the network may contain cycles. Various plans for the connections were proposed, and the complicated phase of evaluation of them has begun. 

One of the criteria that has to be taken into account is the reliability of the created network. To evaluate it, we assume that the worst event that can happen is a malfunction in one of the joining points at the power plants, which might cause the network to split into several parts. While each of these parts could still work, each of them would have to cope with the problems, so it is essential to minimize the number of parts into which the network will split due to removal of one of the joining points. 

Your task is to write a software that would help evaluating this risk. Your program is given a description of the network, and it should determine the maximum number of non-connected parts from that the network may consist after removal of one of the joining points (not counting the removed joining point itself). 

Input

The input consists of several instances. 

The first line of each instance contains two integers 1 <= P <= 10 000 and C >= 0 separated by a single space. P is the number of power plants. The power plants have assigned integers between 0 and P - 1. C is the number of connections. The following C lines of the instance describe the connections. Each of the lines contains two integers 0 <= p1, p2 < P separated by a single space, meaning that plants with numbers p1 and p2 are connected. Each connection is described exactly once and there is at most one connection between every two plants. 

The instances follow each other immediately, without any separator. The input is terminated by a line containing two zeros. 

Output

The output consists of several lines. The i-th line of the output corresponds to the i-th input instance. Each line of the output consists of a single integer C. C is the maximum number of the connected parts of the network that can be obtained by removing one of the joining points at power plants in the instance.

Sample Input

3 3
0 1
0 2
2 1
4 2
0 1
2 3
3 1
1 0
0 0

Sample Output

1
2
2

Source

 
 
题意:有N个核电站,问去掉一个点,最多能使N个核电站分成几部份?

思路:求出去每去掉每个割点子图被分成的个数,取其中最大的。再加上原来有多少个图。
 
如果在图G中去掉一个顶点(自然同时去掉与该顶点相关联的所有边)后图的连通分支数增加,则称该顶点为G的割点(cut-vertex)。
 
 
 
割点就是去掉这个点会导致一个地方不连通.
也就是说,原来有w个连通的部分,去掉该点得到了w+1个连通的部分
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=10010;

struct Edge{
    int to,nxt;
}edge[N<<2];

int head[N],vis[N],dfn[N],low[N],cut[N];    //cut[u] 表示u这个点割边数
int cnt,k,root;

void addedge(int cu,int cv){
    edge[cnt].to=cv;
    edge[cnt].nxt=head[cu];
    head[cu]=cnt++;
}

void Tarjan(int u,int fa){  //割点模板
    int son=0;
    vis[u]=1;
    dfn[u]=low[u]=++k;
    for(int i=head[u];i!=-1;i=edge[i].nxt){
        int v=edge[i].to;
        if(vis[v]==1 && v!=fa)
            low[u]=min(low[u],dfn[v]);
        if(!vis[v]){
            Tarjan(v,u);
            son++;
            low[u]=min(low[u],low[v]);
            if((u==root && son>1) || (u!=root && dfn[u]<=low[v]))
                cut[u]++;   //cut[u] 表示u这个点割边数
        }
    }
    vis[u]=2;
}

int main(){

    //freopen("input.txt","r",stdin);

    int n,m;
    while(~scanf("%d%d",&n,&m) && n){
        if(m==0){
            printf("%d\n",n-1);
            continue;
        }
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        memset(cut,0,sizeof(cut));
        memset(dfn,0,sizeof(dfn));
        cnt=0;
        int u,v;
        while(m--){
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        int ans=0;
        int MAX=0;
        for(int i=0;i<n;i++){
            if(!dfn[i]){
                ans++;
                k=0;
                root=i;
                Tarjan(i,-1);
            }
            MAX=max(MAX,cut[i]);     //取最大的
        }
        printf("%d\n",ans+MAX);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值