例题 3-5 谜题 uva227 Puzzle

A children’s puzzle that was popular 30 years ago consisted of a 5×5 frame which contained 24 small
squares of equal size. A unique letter of the alphabet was printed on each small square. Since there
were only 24 squares within the frame, the frame also contained an empty position which was the same
size as a small square. A square could be moved into that empty position if it were immediately to the
right, to the left, above, or below the empty position. The object of the puzzle was to slide squares
into the empty position so that the frame displayed the letters in alphabetical order.
The illustration below represents a puzzle in its original configuration and in its configuration after
the following sequence of 6 moves:
1) The square above the empty position moves.
2) The square to the right of the empty position moves.
3) The square to the right of the empty position moves.
4) The square below the empty position moves.
5) The square below the empty position moves.
6) The square to the left of the empty position moves.
Write a program to display resulting frames given their initial configurations and sequences of moves.
Input
Input for your program consists of several puzzles. Each is described by its initial configuration and
the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting
configuration. Subsequent lines give the sequence of moves.
The first line of the frame display corresponds to the top line of squares in the puzzle. The other
lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains
exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost
square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.
The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square
moves into the empty position. A denotes that the square above the empty position moves; B denotes
that the square below the empty position moves; L denotes that the square to the left of the empty
position moves; R denotes that the square to the right of the empty position moves. It is possible that
there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move
occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread
over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.
Output
Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). If
the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final
configuration should be displayed.
Format each line for a final configuration so that there is a single blank character between two
adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior
position, then it will appear as a sequence of 3 blanks — one to separate it from the square to the left,
one for the empty position itself, and one to separate it from the square to the right.
Separate output from different puzzle records by one blank line.
Note: The first record of the sample input corresponds to the puzzle illustrated above.
Sample Input
TRGSJ
XDOKI
M VLN
WPABE
UQHCF
ARRBBL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAA
LLLL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAAAABBRRRLL0
Z
Sample Output
Puzzle #1:
T R G S J
X O K L I
M D V B N
W P A E
U Q H C F
Puzzle #2:
A B C D
F G H I E
K L M N J
P Q R S O
T U V W X
Puzzle #3:
This puzzle has no final configuration.

有  一个4*4的网格,其中恰好有一个 格子是空的 其他的 格子  各有一个字母 现在 给你四种操作    也就是   A,B,L,R分别表示把空格上下左右的相邻字母 移动到 空格内    现在  开始输入    输入 : 前四行 是 网格 之中的字母    然后紧接着的是   一系列操作 

如果  输入不正确的话   就输出

This puzzle has no final configuration.
简单的 一个 拼图模拟题 就是 输入输出 太坑 (泪奔).
----还没看出来 格式 哪里错了------
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    char a[7][7],b[100];
    int i,j,m,n,l,x,y,count=1,boom;
    while(gets(a[0]))      //输入  第一行的 数据
    {
        if(a[0][0]=='Z')   //如果 出现了Z  就代表 程序 结束
            break;
        for(i=1;i<=4;i++)  //如果没有结束的 话 那么就输入 剩下的  四行 数据
            gets(a[i]);
        for(i=0;;i++)
        {
            scanf("%c",&b[i]);
            if(b[i]=='0')
                break;
        }
        //scanf("%s",b);     //   输入指令 .
        l=strlen(b)-1;    //得到指令的长度    (因为 指令  以 0 作为结束 所以...)
        for(i=0;i<5;i++)
        {
            for(j=0;j<5;j++)
            {
                if(a[i][j]==' ')
                    {
                        x=i;      //现在  得到了  空格 在 4*4 格子中的
                        y=j;
                        i=555;
                        break;
                    }
            }
            if(i==555)
                break;
        }
        for(i=0;i<l;i++)
        {
            if(b[i]=='A')
            {
                if(x-1<0)
                {
                    boom=1;
                    break;
                }
                swap(a[x-1][y],a[x][y]);
                x--;
            }
            else
                if(b[i]=='B')
            {
                if(x+1>4)
                {
                    boom=1;
                    break;
                }
                swap(a[x+1][y],a[x][y]);
                x++;
            }
            else
                if(b[i]=='R')
            {
                if(y+1>4)
                {
                    boom=1;
                    break;
                }
                swap(a[x][y+1],a[x][y]);
                y++;
            }
            else
                if(b[i]=='L')
            {
                if(y-1<0)
                {
                    boom=1;
                    break;
                }
                swap(a[x][y],a[x][y-1]);
                y--;
            }
        }
        if(count!=1)
            printf("\n");
        printf("Puzzle #%d:\n",count++);
        if(boom==1)
        {
            printf("This puzzle has no final configuration.\n");
            boom=3;
        }
        else
        for(i=0;i<5;i++)
        {
            printf("%c",a[i][0]);
            for(j=1;j<5;j++)
            {
                printf(" %c",a[i][j]);
            }
            printf("\n");
        }
        memset(a,'0',sizeof(a));
        getchar();
    }
    return 0;
}
 
 

 



转载于:https://www.cnblogs.com/A-FM/p/5218397.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值