[ACM] ZOJ 3725 Painting Storages (DP计数+组合)

Painting Storages

Time Limit: 2 Seconds       Memory Limit: 65536 KB

There is a straight highway with N storages alongside it labeled by 1,2,3,...,N. Bob asks you to paint all storages with two colors: red and blue. Each storage will be painted with exactly one color.

Bob has a requirement: there are at least M continuous storages (e.g. "2,3,4" are 3 continuous storages) to be painted with red. How many ways can you paint all storages under Bob's requirement?

Input

There are multiple test cases.

Each test case consists a single line with two integers: N and M (0<N, M<=100,000).

Process to the end of input.

Output

One line for each case. Output the number of ways module 1000000007.

Sample Input
4 3 
Sample Output
3

Author:  ZHAO, Kui
Contest:  ZOJ Monthly, June 2013

解题思路:

这道题和省赛上的一道非常像啊。

假设曾经做过,省赛的时候也不会没思路。

。。

这道题单纯用组合是不行的。。。

题意为:用红蓝两种颜色给N个仓库(标号1—N)涂色。要求至少有M个连续的仓库涂成红色,问一共能够的涂色方案。

结果模1000000007

dp[i] 为 前i个仓库满足至少M个连续仓库为红色的方法数。

那么dp[M]肯定为1。 dp[0,1,2,3,......M-1] 均为0.

在求dp[i]的时候,有两种情况

一。前i-1个仓库涂色已经符合题意,那么第i个仓库涂什么颜色都能够,有 dp[i] = 2*dp[i-1] ;(有可能超出范围,别忘了mod)

二。加上第i个仓库涂为红色才构成M个连续仓库为红色。那么 区间 [i-m+1, i]。为红色,第i-m个仓库肯定是蓝色并且从1到i-m-1个仓库肯定是不符合题意的涂色。所以用1到i-m-1的仓库的全部涂色方法 2^(i-m-1) 减去符合题意的方法数dp[i-m-1] 。所以方法数为2^(i-m-1) - dp[i-m-1] 

代码:

#include <iostream>
#include <string.h>
using namespace std;
const int mod=1000000007;
const int maxn=100005;
int power[maxn+1];
int dp[maxn];//前i个仓库满足m个仓库为红色的方法数
int n,m;

void getPower()//预处理出2的多少次方
{
    power[0]=1;
    for(int i=1;i<=maxn;i++)
        power[i]=power[i-1]*2%mod;
}


int main()
{
    getPower();
    while(cin>>n>>m)
    {
        memset(dp,0,sizeof(dp));
        dp[m]=1;
        for(int i=m+1;i<=n;i++)
            dp[i]=(dp[i-1]*2%mod+power[i-m-1]-dp[i-m-1])%mod;
        cout<<dp[n]<<endl;
    }
    return 0;
}


转载于:https://www.cnblogs.com/clnchanpin/p/7202747.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值