HDU4403:A very hard Aoshu problem(DFS暴搜)


detail:http://blog.csdn.net/sr_19930829/article/details/39206145?utm_source=tuicool&utm_medium=referral

A very hard Aoshu problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1528    Accepted Submission(s): 1048


Problem Description
Aoshu is very popular among primary school students. It is mathematics, but much harder than ordinary mathematics for primary school students. Teacher Liu is an Aoshu teacher. He just comes out with a problem to test his students:

Given a serial of digits, you must put a '=' and none or some '+' between these digits and make an equation. Please find out how many equations you can get. For example, if the digits serial is "1212", you can get 2 equations, they are "12=12" and "1+2=1+2". Please note that the digits only include 1 to 9, and every '+' must have a digit on its left side and right side. For example, "+12=12", and "1++1=2" are illegal. Please note that "1+11=12" and "11+1=12" are different equations.
 

Input
There are several test cases. Each test case is a digit serial in a line. The length of a serial is at least 2 and no more than 15. The input ends with a line of "END".
 

Output
For each test case , output a integer in a line, indicating the number of equations you can get.
 

Sample Input
 
  
1212 12345666 1235 END
 

Sample Output
 
  
2 2 0
 

Source
题意:给定一个字符串,要求插入一个=号和若干个+号使式子成立。

思路:枚举等号的位置,依次将等号左边的所有情况计算出来同时计算等号右边的看是否匹配。

# include <stdio.h>
# include <string.h>
char s[20];
int num[20][20], ans, len;
void init()
{
    for(int i=1; i<=len; ++i)
    {
        num[i][i] = s[i]-'0';
        for(int j=i+1; j<=len; ++j)
            num[i][j] = num[i][j-1]*10 + s[j] - '0';
    }
}
void dfsr(int pos, int leftsum, int sum)
{
    if(pos > len)
    {
        if(sum == leftsum)
            ++ans;
        return;
    }
    for(int i=pos; i<=len; ++i)
        dfsr(i+1, leftsum, sum+num[pos][i]);
}
void dfsl(int equ, int pos, int sum)
{
    if(pos > equ)
        dfsr(equ+1, sum, 0);
    for(int i=pos; i<=equ; ++i)
        dfsl(equ, i+1, sum+num[pos][i]);
}
int main()
{
    while(~scanf("%s",s+1))
    {
        if(s[1] == 'E')
            break;
        len = strlen(s+1);
        memset(num, 0, sizeof(num));
        ans = 0;
        init();
        for(int i=1; i<=len; ++i)
            dfsl(i, 1, 0);
        printf("%d\n",ans);
    }
    return 0;
}



转载于:https://www.cnblogs.com/junior19/p/6730061.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值