图片

Building configuration...

 
Current configuration : 2303 bytes
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname R2
boot-start-marker
boot-end-marker
no aaa new-model
memory-size iomem 5
ip cef
no ip domain lookup
ip sla monitor 1
 type echo protocol ipIcmpEcho 192.168.23.3
 request-data-size 1
 frequency 10
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
 type echo protocol ipIcmpEcho 192.168.24.4
 request-data-size 1
 frequency 10
ip sla monitor schedule 2 life forever start-time now
track 1 rtr 1 reachability
track 2 rtr 2 reachability
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip policy route-map MAP
 duplex auto
 speed auto
interface FastEthernet1/0
 ip address 192.168.23.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
interface FastEthernet2/0
 ip address 192.168.24.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 FastEthernet1/0 192.168.23.3 track 1
ip route 0.0.0.0 0.0.0.0 FastEthernet2/0 192.168.24.4 track 2
ip nat inside source route-map NAT1 interface FastEthernet1/0 overload
ip nat inside source route-map NAT2 interface FastEthernet2/0 overload
ip nat inside source route-map NAT3 interface FastEthernet2/0 overload
ip nat inside source route-map NAT4 interface FastEthernet1/0 overload
access-list 1 permit 192.168.23.3
access-list 2 permit 192.168.24.4
access-list 100 permit ip 192.168.1.1 0.0.0.254 any
access-list 101 permit ip 192.168.1.0 0.0.0.254 any
route-map MAP permit 10
 match ip address 100
 set ip next-hop verify-availability 192.168.23.3 1 track 1
route-map MAP permit 20
 match ip address 101
 set ip next-hop verify-availability 192.168.24.4 2 track 2
route-map NAT3 permit 10
 match ip address 101
 match ip next-hop 2
route-map NAT2 permit 10
 match ip address 100
route-map NAT1 permit 10
 match ip address 100
 match ip next-hop 1
route-map NAT4 permit 10
 match ip address 101
control-plane
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
end