NAT #show run
!
interface FastEthernet0/0
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 no sh
!
interface Serial1/1
 ip address 222.95.1.1 255.255.255.252
 ip nat outside
 no sh
!
ip nat inside source list 1 interface Serial1/1 overload
ip nat inside source static tcp 192.168.10.10 80 222.95.1.1 80 extendable
ip route 0.0.0.0 0.0.0.0 Serial1/1
ip http server
!
!
access-list 1 permit 192.168.10.0 0.0.0.255
!
#######################################################
ISP#show run
!
!
interface Loopback0
 ip address 200.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.0.0.138 255.255.255.0
 no sh
!
interface Serial1/0
 ip address 222.95.1.2 255.255.255.252
 no sh
!
ip classless
ip route 100.1.1.0 255.255.255.0 FastEthernet0/0
ip route 222.95.1.0 255.255.255.252 Serial1/0
ip http server
!
######################################################
r3#show run
!
interface FastEthernet0/0
 ip address 192.168.10.10 255.255.255.0
 no ip route-cache
 no sh
!
ip default-gateway 192.168.10.1
ip http server
!
!