Java SDUT-2562_相似三角形

相似三角形

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

给出两个三角形的三条边,判断是否相似。

Input

多组数据,给出6正个整数,a1,b1,c1,a2,b2,c2,分别代表两个三角形。(边长小于100且无序)

Output

如果相似输出YES,如果不相似输出NO,如果三边组不成三角形也输出NO。

Sample Input

1 2 3 2 4 6
3 4 5 6 8 10
3 4 5 7 8 10

Sample Output

NO
YES
NO

import java.util.*;

public class Main
{
    public static void main(String[] args)
    {
        Scanner cin = new Scanner(System.in);
        san a,b;
        while(cin.hasNextLine())
        {
            a = new san(cin.nextInt(),cin.nextInt(),cin.nextInt());
            b = new san(cin.nextInt(),cin.nextInt(),cin.nextInt());
            if(judge(a,b)==0)
                System.out.println("NO");
            else
                System.out.println("YES");
        }
        cin.close();
    }
    static int judge(san a,san b)
    {
        a.pai();
        b.pai();
        if(a.a+a.b<=a.c||b.a+b.b<=b.c)
            return 0;
        if(a.a/b.a==a.b/b.b&&a.b/b.b==a.c/b.c)
            return 1;
        return 0;
    }
}

class san
{
    double a,b,c;
    san(int a,int b,int c)
    {
        this.a = a;
        this.b = b;
        this.c = c;
    }
    void pai()
    {
        double t;
        if(a>b)
        {
            t = a;
            a = b;
            b = t;
        }
        if(a>c)
        {
            t = a;
            a = c;
            c = t;
        }
        if(b>c)
        {
            t = b;
            b = c;
            c = t;
        }
    }
}

转载于:https://www.cnblogs.com/luoxiaoyi/p/9889894.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值