使三层交换机实现DHCP功能--华为

一、实验拓扑图
使三层交换机实现DHCP功能--华为


二、实验目的
1.让三层交换机实现DHCP功能和路由功能
2.可以使PC1、 PC2、 PC3、 PC4之间相互ping通


三、实验所需的设备以及相关配置
1.四台PC机 、两台二层交换机、一台三层交换机
2.vlan10与vlan20的地址池配置

vlan网段网关子网掩码DNS
vlan10192.168.1.0192.168.1.254255.255.255.08.8.8.8
vlan20192.168.2.0192.168.2.254255.255.255.08.8.8.8

3.三层交换机vlan网关设置

vlan网关 /子网掩码
vlan20192.168.1.254/24
vlan20192.168.2.254/24

四、实验步骤
1.首先把四台PC机设置dhcp功能
2.在SW2中设置vlan10,把Ethernet0/0/1接口thernet0/0/2接口thernet0/0/3接口都加入到vlan10中。

**<Huawei>system-view**    //进入系统模式

[Huawei]vlan 10    //创建vlan10 
[Huawei-vlan10]quit    //退出

[Huawei]port-group group-member e0/0/1 to e0/0/3   //进入1-3接口
[Huawei-port-group]port link-type access   //设置接口模式为接入
[Huawei-port-group]port default vlan 10    //把接口添加进vlan10
[Huawei-port-group]quit     //退出

3.在SW3中设置vlan20,把Ethernet0/0/1接口thernet0/0/2接口thernet0/0/3接口都加入到vlan20中。

**<Huawei>system-view**    //进入系统模式

[Huawei]vlan 20    //创建vlan20 
[Huawei-vlan20]quit    //退出

[Huawei]port-group group-member e0/0/1 to e0/0/3   //进入1-3接口
[Huawei-port-group]port link-type access   //设置接口模式为接入
[Huawei-port-group]port default vlan 20    //把接口添加进vlan20
[Huawei-port-group]quit     //退出

4.在SW1三层交换机中设置vlan10和vlan20
设置两个vlan的IP路由地址
把GE0/0/1和GE0/0/2接口加入vlan10和vlan20中
设置两个vlan的地址池,开启DHCP并把两个vlan加入DHCP

**<Huawei>system-view**     //进入系统模式

[Huawei]vlan batch 10 20     //创建vlan10和vlan20

[Huawei]int   Vlanif  10    //进入vlan10
[Huawei-Vlanif10]undo  shutdown    //开启端口
[Huawei-Vlanif10]ip address 192.168.1.254  24    //设置网关和子网掩码
[Huawei-Vlanif10]quit    //退出

[Huawei]int   Vlanif  20    //进入vlan20
[Huawei-Vlanif10]undo  shutdown    //开启端口
[Huawei-Vlanif10]ip address 192.168.2.254  24    //设置网关和子网掩码
[Huawei-Vlanif10]quit    //退出

[Huawei]int g0/0/1   //进入端口GE0/0/1
[Huawei-GigabitEthernet0/0/1]port link-type access   //把端口设置为接入模式
[Huawei-GigabitEthernet0/0/1]port default vlan 10    //把端口加入vlan10
[Huawei-GigabitEthernet0/0/1]quit     //退出

[Huawei]int g0/0/2   //进入端口GE0/0/2
[Huawei-GigabitEthernet0/0/2]port link-type access   //把端口设置为接入模式
[Huawei-GigabitEthernet0/0/2]port default vlan 20    //把端口加入vlan20
[Huawei-GigabitEthernet0/0/2]quit     //退出

[Huawei]ip pool vlan10   //创建地址池vlan10
[Huawei-ip-pool-vlan10]network 192.168.1.0 mask 255.255.255.0   //设置网段
[Huawei-ip-pool-vlan10]gateway-list 192.168.1.254     //设置网关
[Huawei-ip-pool-vlan10]dns-list 8.8.8.8     //设置dns
[Huawei-ip-pool-vlan10]lease day 3    //设置租约时间
[Huawei-ip-pool-vlan10]excluded-ip-address 192.168.1.253   //去除不想分配的地址
[Huawei-ip-pool-vlan10]quit   //退出

[Huawei]ip pool vlan20   //创建地址池vlan20
[Huawei-ip-pool-vlan20]network 192.168.2.0 mask 255.255.255.0   //设置网段
[Huawei-ip-pool-vlan20]gateway-list 192.168.2.254     //设置网关
[Huawei-ip-pool-vlan20]dns-list 8.8.8.8     //设置dns
[Huawei-ip-pool-vlan20]lease day 3    //设置租约时间
[Huawei-ip-pool-vlan20]excluded-ip-address 192.168.2.253   //去除不想分配的地址
[Huawei-ip-pool-vlan20]quit   //退出

[Huawei]dhcp enable   //开启dhcp

[Huawei]int Vlanif 10    //进入vlan10内
[Huawei-Vlanif10]dhcp select global   //在vlan10内设置dhcp为全局模式
[Huawei-Vlanif10]quit   //退出

[Huawei]int Vlanif 20    //进入vlan20内
[Huawei-Vlanif20]dhcp select global   //在vlan20内设置dhcp为全局模式
[Huawei-Vlanif20]quit   //退出

五、实验结果验证及总结
使三层交换机实现DHCP功能--华为
使三层交换机实现DHCP功能--华为
使三层交换机实现DHCP功能--华为
使三层交换机实现DHCP功能--华为
通过图片可以看出三层交换机实现DHCP功能并且使四台PC机自动获取地址。

转载于:https://blog.51cto.com/13559661/2060789

相关资源:三层交换机DHCP配置
已标记关键词 清除标记
表情包
插入表情
评论将由博主筛选后显示,对所有人可见 | 还能输入1000个字符
相关推荐
三层交换机配置DHCP的解决方案 一,如果不用交换机的DHCP功能而是利用PC的DHCP功能!   1.在交换机上配置DHCP服务器:   ip dhcp-server 192.168.0.69   2.在交换机中为每个VLAN设置同样的DHCP服务器的IP地址: interface Vlan11 ip address 192.168.1.254 255.255.255.0 ip helper-address 192.168.0.69 DHCP Server IP interface Vlan12 ip address 192.168.2.254 255.255.255.0 ip helper-address 192.168.0.69 DHCP Server IP   3.在DHCP服务器上设置网络地址分别为192.168.1.0、192.168.2.0的作用域,并将这些作用域的“路   由器“选项设置为对应VLAN的接口IP地址。   二 利用三层交换机自带的DHCP功能实现多VLAN的IP地址自动分配   (一) 配置方法一   1.同时为多个VLAN的客户机分配地址   2.VLAN内有部分地址采用手工分配的方式   3.为客户指定网关、Wins服务器等   4.VLAN 2的地址租用有效期限为1天,其它为3天   5.按MAC地址为特定用户分配指定的IP地址   最终配置如下: ip dhcp excluded-address 10.1.1.1 10.1.1.19 //不用于动态地址分配的地址 ip dhcp excluded-address 10.1.1.240 10.1.1.254 ip dhcp excluded-address 10.1.2.1 10.1.2.19 ! ip dhcp pool global //global是pool name, 由用户指定 network 10.1.0.0 255.255.0.0 //动态分配的地址段 domain-name client.com //为客户机配置域后缀 dns-server 10.1.1.1 10.1.1.2 //为客户机配置dns服务器 netbios-name-server 10.1.1.5 10.1.1.6 //为客户机配置wins服务器 netbios-node-type h-node //为客户机配置节点模式(影响名称解释的顺利,如h-node=先通过wins服务器解释...) lease 3 //地址租用期限: 3天 ip dhcp pool vlan1 network 10.1.1.0 255.255.255.0 //本pool是global的子pool, 将从global pool继承domain-name等 option default-router 10.1.1.100 10.1.1.101 //为客户机配置默认网关 ! ip dhcp pool vlan2 //为另一VLAN配置的pool network 10.1.2.0 255.255.255.0 default-router 10.1.2.100 10.1.2.101 lease 1 ! ip dhcp pool vlan1_john //总是为MAC地址为...的机器分配...地址 host 10.1.1.21 255.255.255.0 client-identifier 010050.bade.6384 //client-identifier=01加上客户机网卡地址 !ip dhcp pool vlan1_tom host 10.1.1.50 255.255.255.0 client-identifier 010010.3ab1.eac8
<p> <b><span style="background-color:#FFE500;">【超实用课程内容】</span></b> </p> <p> <br /> </p> <p> <br /> </p> <p> 本课程内容包含讲解<span>解读Nginx的基础知识,</span><span>解读Nginx的核心知识、带领学员进行</span>高并发环境下的Nginx性能优化实战,让学生能够快速将所学融合到企业应用中。 </p> <p> <br /> </p> <p style="font-family:Helvetica;color:#3A4151;font-size:14px;background-color:#FFFFFF;"> <b><br /> </b> </p> <p style="font-family:Helvetica;color:#3A4151;font-size:14px;background-color:#FFFFFF;"> <b><span style="background-color:#FFE500;">【课程如何观看?】</span></b> </p> <p style="font-family:Helvetica;color:#3A4151;font-size:14px;background-color:#FFFFFF;"> PC端:<a href="https://edu.csdn.net/course/detail/26277"><span id="__kindeditor_bookmark_start_21__"></span></a><a href="https://edu.csdn.net/course/detail/27216">https://edu.csdn.net/course/detail/27216</a> </p> <p style="font-family:Helvetica;color:#3A4151;font-size:14px;background-color:#FFFFFF;"> 移动端:CSDN 学院APP(注意不是CSDN APP哦) </p> <p style="font-family:Helvetica;color:#3A4151;font-size:14px;background-color:#FFFFFF;"> 本课程为录播课,课程永久有效观看时长,大家可以抓紧时间学习后一起讨论哦~ </p> <p style="font-family:"color:#3A4151;font-size:14px;background-color:#FFFFFF;"> <br /> </p> <p class="ql-long-24357476" style="font-family:"color:#3A4151;font-size:14px;background-color:#FFFFFF;"> <strong><span style="background-color:#FFE500;">【学员专享增值服务】</span></strong> </p> <p class="ql-long-24357476" style="font-family:"color:#3A4151;font-size:14px;background-color:#FFFFFF;"> <b>源码开放</b> </p> <p class="ql-long-24357476" style="font-family:"color:#3A4151;font-size:14px;background-color:#FFFFFF;"> 课件、课程案例代码完全开放给你,你可以根据所学知识,自行修改、优化 </p> <p class="ql-long-24357476" style="font-family:"color:#3A4151;font-size:14px;background-color:#FFFFFF;"> 下载方式:电脑登录<a href="https://edu.csdn.net/course/detail/26277"></a><a href="https://edu.csdn.net/course/detail/27216">https://edu.csdn.net/course/detail/27216</a>,播放页面右侧点击课件进行资料打包下载 </p> <p> <br /> </p> <p> <br /> </p> <p> <br /> </p>
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页