1.在基于 IOS的交换机上设置主机名/系统名:
switch(config)# hostname hostname
在基于CLI的交换机上设置主机名/系统名:
switch(enable) set system name name-string

2.在基于IOS的交换机上设置登录口令:
switch(config)# enable password level 1 password
在基于CLI的交换机上设置登录口令:
switch(enable) set password
switch(enable) set enalbepass

3.在基于IOS的交换机上设置远程访问:
switch(config)# interface vlan 1
switch(config-if)# ip address ip-address netmask
switch(config-if)# ip default-gateway ip-address
在基于CLI的交换机上设置远程访问:
switch(enable) set interface sc0 ip-address netmask broadcast-address
switch(enable) set interface sc0 vlan
switch(enable) set ip route default gateway

4.在基于IOS的交换机上启用和浏览CDP信息:
switch(config-if)# cdp enable
switch(config-if)# no cdp enable
为了查看Cisco邻接设备的CDP通告信息:
switch# show cdp interface [type modle/port]
switch# show cdp neighbors [type module/port] [detail]
在基于CLI的交换机上启用和浏览CDP信息:
switch(enable) set cdp {enable|disable} module/port
为了查看Cisco邻接设备的CDP通告信息:
switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]

5.基于IOS的交换机的端口描述:
switch(config-if)# description description-string
基于CLI的交换机的端口描述:
switch(enable)set port name module/number description-string

6.在基于IOS的交换机上设置端口速度:
switch(config-if)# speed{10|100|auto}
在基于CLI的交换机上设置端口速度:
switch(enable) set port speed moudle/number {10|100|auto}
switch(enable) set port speed moudle/number {4|16|auto}

7.在基于IOS的交换机上设置以太网的链路模式:
switch(config-if)# duplex {auto|full|half}
在基于CLI的交换机上设置以太网的链路模式:
switch(enable) set port duplex module/number {full|half}

8.在基于IOS的交换机上配置静态VLAN:
switch# vlan database
switch(vlan)# vlan vlan-num name vla

switch(vlan)# exit
switch# configure teriminal
switch(config)# interface interface module/number
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan vlan-num
switch(config-if)# end
在基于CLI的交换机上配置静态VLAN:
switch(enable) set vlan vlan-num [name name]
switch(enable) set vlan vlan-num mod-num/port-list

9. 在基于IOS的交换机上配置VLAN中继线:
switch(config)# interface interface mod/port
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk encapsulation {isl|dotlq}
switch(config-if)# switchport trunk allowed vlan remove vlan-list
switch(config-if)# switchport trunk allowed vlan add vlan-list
在基于CLI的交换机上配置VLAN中继线:
switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
Vlan-range [isl|dotlq|dotl0|lane|negotiate]

10.在基于IOS的交换机上配置VTP管理域:
switch# vlan database
switch(vlan)# vtp domain domain-name
在基于CLI的交换机上配置VTP管理域:
switch(enable) set vtp [domain domain-name]

11.在基于IOS的交换机上配置VTP 模式:
switch# vlan database
switch(vlan)# vtp domain domain-name
switch(vlan)# vtp {sever|cilent|transparent}
switch(vlan)# vtp password password
在基于CLI的交换机上配置VTP 模式:
switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]

12. 在基于IOS的交换机上配置VTP版本:
switch# vlan database
switch(vlan)# vtp v2-mode
在基于CLI的交换机上配置VTP版本:
switch(enable) set vtp v2 enable

13. 在基于IOS的交换机上启动VTP剪裁:
switch# vlan database
switch(vlan)# vtp pruning
在基于CL I 的交换机上启动VTP剪裁:
switch(enable) set vtp pruning enable

14.在基于IOS的交换机上配置以太信道:
switch(config-if)# port group group-number [distribution {source|destination}]
在基于CLI的交换机上配置以太信道:
switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

15.在基于IOS的交换机上调整根路径成本:
switch(config-if)# spanning-tree [vlan vlan-list] cost cost
在基于CLI的交换机上调整根路径成本:

switch(enable) set spantree portcost moudle/port cost
switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]

16.在基于IOS的交换机上调整端口ID:
switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
在基于CLI的交换机上调整端口ID:
switch(enable) set spantree portpri {mldule/port}priority
switch(enable) set spantree portvlanpri {module/port}priority [vlans]

17. 在基于IOS的交换机上修改STP时钟:
switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
` switch(config)# spanning-tree [vlan vlan-list] max-age seconds
在基于CLI的交换机上修改STP时钟:
switch(enable) set spantree hello interval[vlan]
switch(enable) set spantree fwddelay delay [vlan]
switch(enable) set spantree maxage agingtiame[vlan]

18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征:
switch(config-if)#spanning-tree portfast
在基于CLI的交换机端口上启用或禁用Port Fast 特征:
switch(enable) set spantree portfast {module/port}{enable|disable}

19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征:
switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
在基于CLI的交换机端口上启用或禁用UplinkFast 特征:
switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]

20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令: switch(config)# cluster enable cluster-name

21. 为了从一条中继链路上删除VLAN,可使用下列命令:
switch(enable) clear trunk module/port vlan-range

22. 用show vtp domain 显示管理域的VTP参数.

23. 用show vtp statistics显示管理域的VTP参数.

24. 在Catalyst交换机上定义TrBRF的命令如下:
switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]

25. 在Catalyst交换机上定义TrCRF的命令如下:
switch (enable) set vlan vlan-num [name name] type trcrf
{ring hex-ring-num|decring decimal-ring-num} parent vlan-num

26. 在创建好TrBRF VLAN之后,就可以给它分配交换机端口.对于以太网交换,可以采用如下命令给VLAN分配端口:
switch(enable) set vlan vlan-num mod-num/port-num

27. 命令show spantree显示一个交换机端口的STP状态.

28. 配置一个ELAN的LES和BUS,可以使用下列命令:
ATM (config)# interface atm number.subint multioint
ATM(config-subif)# lane serber-bus ethernet elan-name

29. 配置LECS:
ATM(config)# lane database database-name
ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address
ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address
ATM(lane-config-databade)# name …

30. 创建完数据库后,必须在主接口上启动LECS.命令如下:
ATM(config)# interface atm number
ATM(config-if)# lane config database database-name
ATM(config-if)# lane config auto-config-atm-address

31. 将每个LEC配置到一个不同的ATM子接口上.命令如下:
ATM(config)# interface atm number.subint multipoint
ATM(config)# lane client ethernet vlan-num elan-num

32. 用show lane server 显示LES的状态.

33. 用show lane bus显示bus的状态.

34. 用show lane database显示LECS数据库可内容.

35. 用show lane client显示LEC的状态.

36. 用show module显示已安装的模块列表.

37. 用物理接口建立与VLAN的连接:
router# configure terminal
router(config)# interface media module/port
router(config-if)# description description-string
router(config-if)# ip address ip-addr subnet-mask
router(config-if)# no shutdown

38. 用中继链路来建立与VLAN的连接:
router(config)# interface module/port.subinterface
router(config-ig)# encapsulation[isl|dotlq] vlan-number
router(config-if)# ip address ip-address subnet-mask

39. 用LANE 来建立与VLAN的连接:
router(config)# interface atm module/port
router(config-if)# no ip address
router(config-if)# atm pvc 1 0 5 qsaal
router(config-if)# atm pvc 2 0 16 ilni
router(config-if)# interface atm module/port.subinterface multipoint
router(config-if)# ip address ip-address subnet-mask
router(config-if)# lane client ethernet elan-num
router(config-if)# interface atm module/port.subinterface multipoint
router(config-if)# ip address ip-address subnet-name
router(config-if)# lane client ethernet elan-name
router(config-if)# …

40. 为了在路由处理器上进行动态路由配置,可以用下列IOS命令来进行:
router(config)# ip routing
router(config)# router ip-routing-protocol
router(config-router)# network ip-network-number
router(config-router)# network ip-network-number

41. 配置默认路由:
switch(enable) set ip route default gateway

42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令:
router(config)# interface interface number
router(config-if)# mls rp vlan-id vlan-id-num

43. 在路由处理器启用MLSP:
router(config)# mls rp ip

44. 为了把一个外置的路由处理器接口和交换机安置在同一个VTP域中:
router(config)# interface interface number
router(config-if)# mls rp vtp-domain domain-name

45. 查看指定的VTP域的信息:
router# show mls rp vtp-domain vtp domain name

46. 要确定RSM或路由器上的管理接口,可以在接口模式下输入下列命令:
router(config-if)#mls rp management-interface

47. 要检验MLS-RP的配置情况:
router# show mls rp

48. 检验特定接口上的MLS配置:
router# show mls rp interface interface number

49. 为了在MLS-SE上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:
set mls flow [destination|destination-source|full]

50. 为使MLS和输入访问列表可以兼容,可以在全局模式下使用下列命令:
router(config)# mls rp ip input-acl

51. 当某个交换机的第3层交换失效时,可在交换机的特权模式下输入下列命令:
switch(enable) set mls enable

52. 若想改变老化时间的值,可在特权模式下输入以下命令:
switch(enable) set mls agingtime agingtime

53. 设置快速老化:
switch(enable) set mls agingtime fast fastagingtime pkt_threshold

54. 确定那些MLS-RP和MLS-SE参与了MLS,可先显示交换机引用列表中的内容再确定:
switch(enable) show mls include

55. 显示MLS高速缓存记录:
switch(enable) show mls entry

56. 用命令show in arp显示ARP高速缓存区的内容。

57. 要把路由器配置为HSRP备份组的成员,可以在接口配置模式下使用下面的命令:
router(config-if)# standby group-number ip ip-address

58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:
router(config-if)# standy group-number preempt

59. 访问时间和保持时间参数是可配置的:
router(config-if)# standy group-number timers hellotime holdtime

60. 配置HSRP跟踪:
router(config-if)# standy group-number track type-number interface-priority

61. 要显示HSRP路由器的状态:
router# show standby type-number group brief

62. 用命令show ip igmp确定当选的查询器。

63. 启动IP组播路由选择:
router(config)# ip muticast-routing

64. 启动接口上的PIM:
dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}

65. 启动稀疏-稠密模式下的PIM:
router# ip multicast-routing
router# interface type number
router# ip pim sparse-dense-mode

66. 核实PIM的配置:
dallasr1># show ip pim interface[type number] [count]

67. 显示PIM邻居:
dallasr1># show ip neighbor type number

68. 为了配置RP的地址,命令如下:
dallasr1># ip pim rp-address ip-address [group-access-list-number][override]

69. 选择一个默认的RP:
dallasr1># ip pim rp-address
通告RP和它所服务的组范围:
dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number
为管理范围组通告RP的地址:
dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1
dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255
设定一个RP映像代理:
dallasr1># ip pim send-rp-discovery scope ttl
核实组到RP的映像:
dallasr1># show ip pim rp mapping
dallasr1># show ip pim rp [group-name|group-address] [mapping]

70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value设定TTL阀值:
dallasr1>(config-if)# ip multicast ttl-threshold ttl-value

71. 用show ip pim neighbor显示PIM邻居表。

72. 显示组播通信路由表中的各条记录:
dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]

73. 要记录一个路由器接受和发送的全部IP组播包:
dallasr1> #debug ip mpacket [detail] [access-list][group]

74. 要在CISCO路由器上配置CGMP:
dallasr1>(config-if)# ip cgmp

75.配置一个组播路由器,使之加入某一个特定的组播组:
dallasr1>(config-if)# ip igmp join-group group-address

76. 关闭 CGMP:
dallasr1>(config-if)# no ip cgmp

77. 启动交换机上的CGMP:
dallasr1>(enable) set cgmp enable

78. 核实Catalyst交换机上CGMP的配置情况:
catalystla1>(enable) show config
set prompt catalystla1>
set interface sc0 192.168.1.1 255.255.255.0
set cgmp enable

79. CGMP离开的设置:
Dallas_SW(enable) set cgmp leave

80. 在Cisco设备上修改控制端口密码:
R1(config)# line console 0
R1(config-line)# login
R1(config-line)# password Lisbon
R1(config)# enable password Lilbao
R1(config)# login local
R1(config)# username student password cisco

81. 在Cisco设备上设置控制台及vty端口的会话超时:
R1(config)# line console 0
R1(config-line)# exec-timeout 5 10
R1(config)# line vty 0 4
R1(config-line)# exec-timeout 5 2

82. 在Cisco设备上设定特权级:
R1(config)# privilege configure level 3 username
R1(config)# privilege configure level 3 copy run start
R1(config)# privilege configure level 3 ping
R1(config)# privilege configure level 3 show run
R1(config)# enable secret level 3 cisco

83. 使用命令privilege 可定义在该特权级下使用的命令:
router(config)# privilege mode level level command

84. 设定用户特权级:
router(config)# enable secret level 3 dallas
router(config)# enable secret san-fran
router(config)# username student password cisco

85. 标志设置与显示:
R1(config)# banner motd ‘unauthorized access will be prosecuted!’

86. 设置vty访问:
R1(config)# access-list 1 permit 192.168.2.5
R1(config)# line vty 0 4
R1(config)# access-class 1 in

87. 配置HTTP访问:
Router3(config)# access-list 1 permit 192.168.10.7
Router3(config)# ip http sever
Router3(config)# ip http access-class 1
Router3(config)# ip http authentication local
Router3(config)# username student password cisco

88. 要启用HTTP访问,请键入以下命令:
switch(config)# ip http sever

89. 在基于set命令的交换机上用setCL1启动和核实端口安全:
switch(enable) set port security mod_num/port_num…enable mac address
switch(enable) show port mod_num/port_num
在基于CiscoIOS命令的交换机上启动和核实端口安全:
switch(config-if)# port secure [mac-mac-count maximum-MAC-count]
switch# show mac-address-table security [type module/port]

90. 用命令access-list在标准通信量过滤表中创建一条记录:
Router(config)# access-list access-list-number {permit|deny} source-address [source-address]

91. 用命令access-list在扩展通信量过滤表中创建一条记录:
Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]

92. 对于带内路由更新,配置路由更新的最基本的命令格式是:
R1(config-router)#distribute-list access-list-number|name in [type number]

93. 对于带外路由更新,配置路由更新的最基本的命令格式是:
R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process| autonomous-system-number

94. set snmp命令选项:
set snmp community {read-only|ready-write|read-write-all}[community_string]

95. set snmp trap 命令格式如下:
set snmp trap {enable|disable}
[all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]
set snmp trap rvcr_addr rcvr_community

96. 启用SNMP chassis 陷阱:
Console>(enable) set snmp trap enable chassis

97. 启用所有SNMP chassis 陷阱:
Console>(enable) set snmp trap enable

…………以下由about于2002年12月6日增加…………
98. 禁用SNMP chassis 陷阱:
Console>(enable) set snmp trap disable chassis

99. 给SNMP陷阱接收表加一条记录:
Console>(enable) set snmp trap 192.122.173.42 public

100. show snmp 输出结果。

101. 命令set snmp rmon enable 的输出结果。

102. 显示SPAN信息:
Consile> show spanCISCO交换机配置命令大全
转自: IXPUB技术社区
 
 
 
 
一、cisco交换机2950网络配置
2950(config)#int vlan1
2950(config-if)#ip address 192.168.1.100 255.255.255.0 ( VLAN1里面设置IP地址)
2950(config)#ip default-gateway 192.168.1.1 (设置默认网关 )
2950(config)#ip name-server 192.168.1.1 (设置域名服务器)
2950(config)#ip domain-name wqs.com (设置域名)
二、端口配置
2950(config)#int f0/1 (进入接口 )
2950(config-if)#speed 100 (设置该接口速率为 100Mb/s)
2950(config-if)#duplex ?
auto Enable AUTO duplex configuration
full Force full duplex operation
half Force half-duplex operation
2950(config-if)#description to_router1 (设置端口描述)
2950#show interfaces fastethernet1 [status] (查看端口配置结果和状态)
三、MAC地址表相关命令
2950(config)#mac-address-table aging-time 100 (设置超时时间为 100S)
2950(config)#mac-address-table permanent 000.0c01.bbcc f0/3 (加入永久地址 )
2950(config)#mac-address-table restricted static 0000.0c02.bbcc f0/6 f0/7 (加入静态地址 )
2950#show mac-address-table (查看整个 MAC地址表)
2950#clear mac-address-table restricted static (清除限制性 MAC址表)
四、 VTP的配置
2950#vlan database (进入 VLAN配置模式)
2950(vlan)#vtp ? (查看 VTP的子命令)
domain Set the name of the VTP administrative domain.
client Set the device to client mode.
server Set the device to server mode.
transparent Set the device to transparent mode.
password Set the password for the VTP administrative domain.
2950(vlan)#vtp domain server (设置本交换机为 SEVER模式)
2950(vlan)#vtp domain wqs (设置域名)
2950(vlan)#vtp pruning (启动修剪模式 )
2950#show vtp status (查看 VTP设置信息)
五、配置VLAN TRUNK端口
2950(config)#int f0/11 (进入 F端口)
2950(config-if)#switchport mode trunk (设置该端口为 TRUNK模式)
2950(config-if)#switchport trunk encapsulation {dot1q | isl | negotiate }(设置 TRUNK封装)
六、创建VLAN
2950#vlan database (进入 VLAN配置模式)
2950(vlan)#vlan 2 (创建 VLAN 2)
VLAN 2 added:
Name:VLAN0002 (系统默认名)
2950(vlan)#vlan 3 name wg_bisheng (创建 VLAN 3,名为网工必胜)
VLAN 3 added:
Name:wg_bisheng
2950(config)#int f0/9 (进入接口配置模式)
2950(config-if)#switchport mode access (设置该接口为 ACCESS模式)
2950(config-if)#switchport access vlan 2 (把端口 9分配给VLAN2)
2950(config-if)#int f0/8
2950(config-if)#switchport mode access
2950(config-if)#switchport access vlan 3
2950(config-if)#end
七、生成树协议的配置
生成树负载均衡实现方法(感谢***天使提醒)
1 使用 STP端口权值实现。
2 使用 STP路径值实现
2950(config)#int f0/11
2950(config-if)#spanning-tree vlan 2 port-priority 10 (将 VLAN2的端口权值设为10)
2950(config-if)#spanning-tree vlan 2 cost 30 (设置 VLAN2生成树路径值为30)
 
 
 
 
  switch>enable 进入特权模式
  switch#config terminal 进入全局配置模式
  switch(config)#hostname 设置 交换机的主机名
  switch(config)#enable secret xxx 设置特权加密口令
  switch(config)#enable password xxa 设置特权非密口令
  使用Telnet远程式管理
  switch(config)#interface vlan 1 进入vlan 1
  switch(config-if)#ip address 设置IP地址
  switch(config-if)#ip default-gateway 设置默认网关
  switch(config)#line vty 0 4 进入虚拟终端
  switch(config-line)#login 允许登录
  switch(config-line)#password xx 设置登录口令
  switch#exit 返回命令
  控制台口令
  switch(config)#line console 0 进入控制台口
  switch(config-line)#login 允许登录
  switch(config-line)#password xx 设置登录口令
  switch#exit 返回命令
  基本接口配置
  switch(config)#interface f0/1 进入f0/1接口
  switch(config-if)#duplex full 配置全双工模式
  switch(config-if)#speed 100 配置速率
  switch(config-if)#description to ***** 接口描述
  switch(config)#ip domain-name ***.com 设置或名 服务器
  switch(config)#mac-address-table aging-time 设置mac表超时时间
  switch#write 保存配置信息
  switch#copy running-config startup-config 保存当前配置nvram
  switch#erase startup-config 清除配置文件
  交换机VLAN设置:
  switch#vlan database 进入VLAN设置
  switch(vlan)#vlan 2 建VLAN 2
  switch(vlan)#name 名字 建VLAN 2的名称
  switch(vlan)#no vlan 2 删vlan 2
  注:删除vlan时原属于此vlan的端口处于非激活状态,直到重新分配为止
  switch(config)#int f0/1 进入端口1
  switch(config-if)#switchport mode access 当前端口工作莫试
  switch(config-if)#switchport access vlan 2 当前端口加入vlan 2
  switch(config-if)#switchport mode trunk 设置为干线
  switch(config-if)#switchport trunk encapsulation dot1q 设置vlan 中继 协议
  switch(config-if)#no switchport mode 或 ( switchport mode access) 禁用干线
  switch(config-if)#switchport trunk allowed vlan add 1,2 ;从Trunk中添加vlans
  switch(config-if)#switchport trunk allowed vlan remove 1,2 ;从Trunk中删除vlans
  switch(config-if)#switchport trunk pruning vlan remove 1,2 ;从Trunk中关闭局部修剪
  以太网通道配置
  switch(config)#interface range fasternet0/1 - 2 将fasternet0/1和0/2 口捆绑 (成双不成单)
  switch(config-if)#channel-group 1 mode on 配置以太通道模式
  switch(config-if)#port-channel load-balance {dst-mac | src-mac}在链路间实现负载均衡
  switch#show etherchannel 1 summary 查看通道信息
  switch#show etherchannel load-balance 查看通道信息
  vtp配置
  switch(config)#vtp domain 设置vtp域名
  switch(config)#vtp password 设置vtp密码
  switch(config)#vtp mode server 设置vtp 服务器模式
  switch(config)#vtp mode client 设置vtp客户机模式
  switch(config)#vtp mode transparent 设置vtp 透明模式
  switch(config)#vtp version 设置vtp版本
  switch(config)#vtp pruning 启用vtp修解
  switch(config)#no vtp pruning 关闭vtp修解
  注:要想从vtp中减少一台交换机只需将该交换机vtp 名更改
  生成树stp:
  switch(config)#spanning-tree vlan 启用stp生成树(基于vlan)
  switch(config)#spanning-tree vlan root primary 指定根交换机(基于vlan)
  switch(config)#spanning-tree vlan root secondary 指定备用根交换机(基于vlan)
  switch(config)#spanning-tree vlan priority 指定交换机优先级(基于vlan)
  switch(config)#no spanning-tree vlan priority 将交换机的优先级恢复默认值(基于vlan)
  switch(config-if)#spanning-tree vlan cost 指定端口成本(起用trunk的端口模式下)
  switch(config-if)#spanning-tree vlan port-prioty 指定交换机端口优先级(基于vlan)
  switch(config-if)#spanning-tree portfast 配置速端口(连接终端设备的端口状态)如pc机
  switch(config)#spanning-tree uplinkfast 配置上行速端口
  注:在配置上行速端口前要先将基于vlan上的网桥优先级,网桥成本恢复默认值。起用了该命令后在进行优先级更改,
  switch(config)#spanning-tree vlan hello-time 配置交换机hello时间(基于vlan)
  switch(config)#spanning-tree vlan forward-time 修改转发延迟计时器(基于vlan)
  switch(config)#spanning-tree vlan max-time 修改最大老化时间(基于vlan)
  注:vlan为可选参数,当没有该参数时将修改所有vlan网桥的优先级及所有的vlan端口成本
  switch#show spanning-tree summery 检测vlan生成树配置
  switch#show spanning-tree vlan detail 浏览详细生成树配置信息
  switch#show spanning-tree interface detail 浏览详细生成树端口配置信息
  交换机显示命令:
  switch#show vtp status 查看vtp配置信息
  switch#show running-config 查看当前配置信息
  switch#show vlan 查看vlan配置信息
  switch#show interface 查看端口信息
  switch#show int f0/0 查看指定端口信息
  switch#dir flash: 查看闪存
  switch#show version 查看当前版本信息
  switch#show mac-address-table aging-time 查看mac超时时间
  switch#show cdp cisco设备发现 协议(可以查看聆接设备)
  switch#show cdp traffic 杳看接收和发送的cdp包统计信息
  switch#show cdp neighbors 查看与该设备相邻的cisco设备
  switch#show interface f0/1 switchport 查看有关switchport的配置
  switch#show cdp neighbors 查看与该设备相邻的cisco设备
  2950交换机密码恢复
  拨下交换机的电源线
  用手按在mode按键上,插上电源线。
  看到出现 flash_init load_helper boot switch: 画面时松开mode键
  在switch:后执行flash_init命令查看flash中的文件
  把config.text 文件改名为"config.old rename flash:config.text flash:config.old
  执行boot命令启动交换机
  交换机出现是否进入配置的对话, 执行no命令
  进入特权模式查看flash文件 执行enable 在switch#show flash:
  把config.old改为config.text rename flash:config.old flash:config.text
  把config.text考入系统的running-config
  copy flash:config.text system:running-config
  重新设置密码并存盘
完成标准
     为交换机添加vlan2和vlan3;处于同一vlan的主机之间可以ping通;处于不同vlan的主机不能ping通。
 
实验拓扑图如下:
 
操作步骤如下:
1 交换机的配置
>en
#conf t
(config)#hostname sw1 设置交换机的主机名
(config)#enable password benet 设置交换机的使能口令
(config)#enable secret nt26 设置交换机加密的使能口令
(config)#line console 0
(config-line)#password 123 设置交换机的 console口令
(config-line)#login
(config-line)#exit
(config)#int vlan1 
(config-if)#ip address 172.16.1.2 255.255.0.0 设置交换机的 ip地址
(config-if)#no sh  启用配置
(config-if)#exit
(config)#ip default-gateway 172.16.1.1 设置交换机的网关
(config)#exit
#show running-config 查看交换机配置信息  
#show mac-address-table 查看交换机 mac地址表
#copy running-config startup-config 保存配置
#erase startup-config 恢复出厂默认值
#reload 重启交换机
 
>en
#vlan database 进入 vlan数据库配置
(vlan)#vlan 2 name vlan2    添加 vlan号及vlan名
(vlan)#vlan 3 name vlan3 添加 vlan号及vlan名
(vlan)#exit
#show vlan brief 查看 vlan信息
#conf t
(config)#int f0/1
(config-if)#switchport access vlan 2     将端口 f0/1添加到vlan 2中
(config-if)#end
#conf t
(config)#int f0/2
(config-if)#switchport access vlan 2     将端口 f0/2添加到vlan 2中
(config-if)#end
#conf t
(config)#int f0/3
(config-if)#switchport access vlan 3     将端口 f0/3添加到vlan 3中
(config-if)#end
#conf t
(config)#int f0/4
(config-if)#swichport access vlan 3      将端口 f0/4添加到vlan 3中
(config-if)#end
#show vlan 2  查看 vlan 2信息
#show vlan 3 查看 vlan 3信息
#copy running-config starup-config 保存配置
  
2 .PC机的配置
在模拟哭器中的各自 PC机中输入命令: winipcfg 设置 IP地址及网关
  PC1:IP 地址 172.16.1.10 255.255.0.0  网关 :172.16.1.1
   PC2:IP 地址 172.16.1.11 255.255.0.0  网关 :172.16.1.1
   PC3:IP 地址 172.16.1.12 255.255.0.0  网关 :172.16.1.1
   PC4:IP 地址 172.16.1.13 255.255.0.0 网关 :172.16.1.1
 
 
经验证:
处于同一vlan的主机之间可以ping通;处于不同vlan的主机之间不能ping通。