UVA 825 Walking on the Safe Side(记忆化搜索)

 

  Walking on the Safe Side 

Square City is a very easy place for people to walk around. The two-way streets run North-South or East-West dividing the city into regular blocks. Most street intersections are safe for pedestrians to cross. In some of them, however, crossing is not safe and pedestrians are forced to use the available underground passages. Such intersections are avoided by walkers. The entry to the city park is on the North-West corner of town, whereas the railway station is on the South-East corner.

 

 


Suppose you want to go from the park to the railway station, and do not want to walk more than the required number of blocks. You also want to make your way avoiding the underground passages, that would introduce extra delay. Your task is to determine the number of different paths that you can follow from the park to the station, satisfying both requirements.

The example in the picture illustrates a city with 4 E-W streets and 5 N-S streets. Three intersections are marked as unsafe. The path from the park to the station is 3 + 4 = 7 blocks long and there are 4 such paths that avoid the underground passages.

 

\epsfbox{p825.eps}

 

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

 

 


The first line of the input contains the number of East-West streets W and the number of North-South streets N. Each one of the following W lines starts with the number of an East-West street, followed by zero or more numbers of the North-South crossings which are unsafe. Streets are numbered from 1.

 

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

 

 


The number of different minimal paths from the park to the station avoiding underground passages.

 

Sample Input 

1

4 5
1
2 2
3 3 5
4

 

Sample Output 

4

题意:一个人要从左上角走到右下角。中间有些点是不能走的,要求出最小步数的路径有多少条。

思路:记忆化搜索,注意输入格式,还有方向只能向下和向右。

 

#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include <limits.h>
const int MAXN = 105, d[2][2] = {{1, 0}, {0, 1}};
int t, n, m, map[MAXN][MAXN], dp[MAXN][MAXN], i, j, ans, Min;

void dfs(int bu, int x, int y) {
	int i;
	if (x == n && y == m) {
		if (Min > bu) {
			Min = bu;
			ans = 0;
		}
		ans ++;
		return;
	}
	for (i = 0; i < 2; i ++) {
		if ((x + d[i][0] >= 1) && (x + d[i][0] <= n) && (y + d[i][1] >= 1) && (y + d[i][1] <= m) && !map[x + d[i][0]][y + d[i][1]] && dp[x + d[i][0]][y + d[i][1]] >= bu + 1) {						
			dp[x + d[i][0]][y + d[i][1]] = bu + 1;
			dfs(bu + 1, x + d[i][0], y + d[i][1]);
		}
	}
}
int main() {
	scanf("%d", &t);
	while (t --) {
		ans = 0;
		Min = INT_MAX;
		memset(map, 0, sizeof(map));
		memset(dp, 0, sizeof(dp));
		scanf("%d%d%", &n, &m);
		char c[105];
		for (i = 1; i <= n; i ++) {
			for (j = 1; j <= m; j ++)
				dp[i][j] = INT_MAX;
			int sb;
			scanf("%d", &sb);
			gets(c);
			int lenc = strlen(c);
			c[lenc] = ' ';
			int num = 0;
			for (j = 0; j <= lenc; j ++) {
				if (isdigit(c[j])) {
					num = num * 10 + c[j] - '0';
				}
				else {
					map[sb][num] = 1;
					num = 0;
				}
			}
		}
		dp[1][1] = 0;
		dfs(0, 1, 1);
		printf("%d\n", ans);
		if (t)
			printf("\n");
	}
	return 0;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值