Period UVALive - 3026

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and
126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N)
we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be
written as AK, that is A concatenated K times, for some string A. Of course, we also want to know
the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains
N (2 ≤ N ≤ 1000000) the size of the string S. The second line contains the string S. The input file
ends with a line, having the number zero on it.
Output
For each test case, output ‘Test case #’ and the consecutive test case number on a single line; then, for
each prefix with length i that has a period K > 1, output the prefix size i and the period K separated
by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4

给定一个长度为n的字符串s,求它每个前缀的最短循环节。换句话说,对于每个i,求一个最大的整数k(如果k 存在),使得s的前i哥字符组成的前缀是某个字符串重复k次得到。输出所有存在k的i和对应的k

比如对于字符串aabaabaabaab,只有当i=2,6,9,12时k存在,且分别为2,2,3,4

#include <algorithm>
#include <iostream>
#include <string>
#include<cstdio>
#include <vector>
#define maxn 1000001
using namespace std;
char p[maxn];
int f[maxn];
int main()
{
    int n,kase = 0;
    while(cin >> n)
    {
        if(!n)
            break;
        cin >> p;
        f[0]=0,f[1]=0;//递推边界初值
        for(int i=1;i<n;i++)
        {
            int j = f[i];
            while(j&&p[i]!=p[j])
                j = f[j];
            f[i+1] = ((p[i]==p[j])?j+1:0);
        }
        printf("Test case #%d\n",++kase);
        for(int i=2;i<=n;i++)
            if(f[i]>0&&i%(i-f[i])==0)
                printf("%d %d\n",i,i/(i-f[i]));//找到i和k
        printf("\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/l609929321/p/6895140.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值