R1的配置如下:
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 199.99.1.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 199.99.1.1 102 broadcast
frame-relay map ip 199.99.1.2 102 broadcast
frame-relay map ip 199.99.1.3 103 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 199.99.1.0 0.0.0.255 area 0
neighbor 199.99.1.3   手工指定邻居,建立单播
neighbor 199.99.1.2   手工指定邻居,建立单播
!

R2的配置如下:
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 199.99.1.2 255.255.255.0
encapsulation frame-relay
ip ospf priority 0     让这个路由器退出DR的选举(设置优先级为0)
serial restart-delay 0
frame-relay map ip 199.99.1.1 201 broadcast
frame-relay map ip 199.99.1.2 201 broadcast
frame-relay map ip 199.99.1.3 201 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 199.99.1.0 0.0.0.255 area 0
!


R3的配置如下:
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 199.99.1.3 255.255.255.0
encapsulation frame-relay
ip ospf priority 0     让这个路由器退出DR的选举
serial restart-delay 0
frame-relay map ip 199.99.1.1 301 broadcast
frame-relay map ip 199.99.1.2 301 broadcast
frame-relay map ip 199.99.1.3 301 broadcast
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 199.99.1.0 0.0.0.255 area 0
!
 
这里面关键要知道,在NBMA的网络中,OSPF的DR需要手工指定,我们用show ip ospf int s1/0看下接口的信息
r1#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up
  Internet Address 199.99.1.1/24, Area 0
  Process ID 10, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 199.99.1.1
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 00:00:20
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 3.3.3.3
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)


我们可以看到 NON_BROADCAST 的网络类型了~