TU 
 
R1 配置
Router(config)#hostname r1                    更改路由器名字
r1(config)#interface loopback 0                  进入回环接口
r1(config-if)#ip address 1.1.1.1 255.255.255.0
r1(config)#interface serial 2/1
r1(config-if)#ip address 10.1.1.1 255.255.255.0
r1(config-if)#no shutdown
r1(config)#router rip                             启用RIP
r1(config-router)#network 10.1.1.0
r1(config-router)#network 1.1.1.0
r1(config-router)#end
 
R2 配置
Router(config)#hostname r2
r2(config)#interface loopback 0
r2(config-if)#ip address 2.2.2.2 255.255.255.0
r2(config)#interface serial 2/1
r2(config-if)#ip address 10.1.1.2 255.255.255.0
r2(config-if)#no shutdown
r2(config)#interface serial 2/2
r2(config-if)#ip address 10.1.2.1 255.255.255.0
r2(config-if)#no shutdown
r2(config)#router rip
r2(config-router)#network 2.2.2.0
r2(config-router)#network 10.1.1.0
r2(config-router)#network 10.1.2.0
r1(config-router)#end
 
R3 配置
Router(config)#hostname r3
r3(config)#interface loopback 0
r3(config-if)#ip address 3.3.3.3 255.255.255.0
r3(config)#interface serial 2/1
r3(config-if)#ip address 10.1.2.2 255.255.255.0
r3(config-if)#no shutdown
r3(config)#router rip
r3(config-router)#network 3.3.3.0
r3(config-router)#network 10.1.2.0
r1(config-router)#end
 
在R1上查看协议
r1#show ip protocols
Routing Protocol is "rip"                 现在使用的是RIP协议
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 13 seconds                30秒更新 距离下次更新还有13秒
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 1, receive any version
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial2/1             1     1 2                                 
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.1.2             120      00:00:00
  Distance: (default is 120)
 
R3路由表
3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.1.2.0 is directly connected, Serial2/1
R       10.1.1.0 [120/1] via 10.1.2.1, 00:00:25, Serial2/1
 
      R表示使用的是RIP协议