NYOJ-506 洗澡

 

洗澡

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
 
描述

Mostrp是个爱干净的好少年。 有一次去澡堂洗澡时发现 澡堂的澡柜编号中没有出现过数字‘4’。 Mostrp 感到很好奇。可能是因为在澡堂老板眼里。数字‘4’是十分不吉利的。

现在Mostrp知道澡柜的最大的编号N,你能帮他算出澡堂一共有多少澡柜吗?

 
输入
有多组数据,每行输入一个N。
( 1 <= N <= 50000 )
输出
输出澡柜的个数,输出占一行。
样例输入
3
5
样例输出
3
4

起来水一题 。。。。
#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>

using namespace std;

int fun(char* s)
{
    int tot = 0;
    int len = strlen(s);
    for(int i = 0; i < len; ++i)
    {
        int cnt = s[i] - '0';
        if(s[i] > '4')
            --cnt;
        tot += cnt * (int)pow(9,len - i -1);
    }
    return tot;
}

int main()
{
    char s[10];
    while(cin >> s)
    {
        cout << fun(s) << endl;
    }
    return 0;
}

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>

using namespace std;

int fun(char* s)
{
    int tot = 0;
    int len = strlen(s);
    for(int i = 0; i < len; ++i)
    {
        int cnt = s[i] - '0';
        if(s[i] > '4')
            --cnt;
        tot += cnt * (int)pow(9,len - i -1);
    }
    return tot;
}

int main()
{
    char s[10];
    while(cin >> s)
    {
        cout << fun(s) << endl;
    }
    return 0;
}

  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值